summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--configure.ac4
2 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 265a53d..f63cafd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,6 @@ EXTRA_DIST = \
.travis.yml \
AUTHORS \
COPYING \
- ChangeLog \
dbus-python.pc.in \
doc/_static/.gitignore \
examples/example-async-client.py \
@@ -357,9 +356,7 @@ $(patsubst %,%.test,$(test_programs)): %.test: Makefile
# === Documentation ===
-@GENERATE_CHANGELOG_RULES@
-
-dist-hook: dist-ChangeLog
+dist-hook:
echo $(VERSION) > $(distdir)/.version
touch $(distdir)/MANIFEST
touch $(distdir)/MANIFEST.in
diff --git a/configure.ac b/configure.ac
index 9bab4ab..d5735d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,7 @@ AC_CONFIG_SRCDIR([dbus_bindings/module.c])
AC_CONFIG_HEADERS(config.h)
AC_USE_SYSTEM_EXTENSIONS
-AM_INIT_AUTOMAKE([1.13 -Wno-portability subdir-objects tar-ustar])
+AM_INIT_AUTOMAKE([1.13 -Wno-portability foreign subdir-objects tar-ustar])
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
@@ -97,8 +97,6 @@ AM_CONDITIONAL([ENABLE_INSTALLED_TESTS], [test "_$enable_installed_tests" = _yes
dnl Building documentation
-AX_GENERATE_CHANGELOG
-
AC_ARG_ENABLE([documentation],
[AC_HELP_STRING([--enable-documentation],
[Enable documentation building (requires sphinx and sphinx_rtd_theme)])],