summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--ChangeLog2
-rw-r--r--Makefile.am9
3 files changed, 7 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 0c1d6c7..5c34b5b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
run-with-tmp-session-bus.conf
test/data
-ChangeLog
*.pyc
*.pyo
.*.sw?
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 0000000..a8ccf81
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,2 @@
+In git versions of dbus-python, please use 'git-log' instead of referring to
+ChangeLog. A changelog is generated from the git history during 'make dist'.
diff --git a/Makefile.am b/Makefile.am
index f2d0232..2e00f70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,12 +26,13 @@ cross-test-client:
# === Documentation ===
-ChangeLog: always-rebuild
- @if test -d $(top_srcdir)/.git; then \
- if git-log --stat > ChangeLog; then \
+dist-hook:
+ chmod u+w $(distdir)/ChangeLog
+ if test -d $(top_srcdir)/.git; then \
+ if git-log --stat > $(distdir)/ChangeLog; then \
: ; \
else \
- git-log > Changelog || exit 1; \
+ git-log > $(distdir)/ChangeLog; \
fi; \
fi