summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 21 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d2f7ea..8738d57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,8 +52,8 @@ EXTRA_DIST = \
tools/check-c-style.sh \
tools/check-coding-style.mk \
tools/check-py-style.sh \
- tools/check-whitespace.sh
- tools/ci-build.sh \
+ tools/check-whitespace.sh \
+ tools/generate-pkginfo.py \
$(NULL)
# === C code ===
@@ -370,13 +370,22 @@ $(patsubst %,%.test,$(test_programs)): %.test: Makefile
dist-hook:
echo $(VERSION) > $(distdir)/.version
+ $(MKDIR_P) $(distdir)/dbus_python.egg-info
touch $(distdir)/MANIFEST
touch $(distdir)/MANIFEST.in
+ touch $(distdir)/dbus_python.egg-info/SOURCES.txt
+ $(PYTHON) $(distdir)/tools/generate-pkginfo.py $(VERSION) $(distdir)/PKG-INFO
+ echo > $(distdir)/dbus_python.egg-info/dependency_links.txt
+ echo _dbus_bindings > $(distdir)/dbus_python.egg-info/top_level.txt
+ echo _dbus_glib_bindings >> $(distdir)/dbus_python.egg-info/top_level.txt
+ echo dbus >> $(distdir)/dbus_python.egg-info/top_level.txt
+ cp $(distdir)/PKG-INFO $(distdir)/dbus_python.egg-info/PKG-INFO
( cd $(distdir) && find -type d -o -print ) | \
LC_ALL=C sort | \
$(SED) -e 's|^\./||' \
> $(distdir)/MANIFEST
sed -e 's/.*/include &/' < $(distdir)/MANIFEST > $(distdir)/MANIFEST.in
+ cp $(distdir)/MANIFEST $(distdir)/dbus_python.egg-info/SOURCES.txt
maintainer-upload:
rsync -tvpP --chmod=ugo=r $(DIST_ARCHIVES) $(DIST_ARCHIVES:%=%.asc) \
@@ -423,31 +432,31 @@ uninstall-local-pycache:
rm -fr $(DESTDIR)$(pythondir)/dbus/mainloop/__pycache__
if ENABLE_DOCUMENTATION
-all: doc/_build/.stamp
+all: doc/html/.stamp
-doc/_build/.stamp: $(nobase_python_PYTHON) \
+doc/html/.stamp: $(nobase_python_PYTHON) \
_dbus_bindings.la \
_dbus_glib_bindings.la \
$(sphinx_sources) \
Makefile \
$(NULL)
- rm -rf doc/_build
- $(MKDIR_P) doc/_build
+ rm -rf doc/html
+ $(MKDIR_P) doc/html
abs_top_srcdir='$(abs_top_srcdir)' \
abs_top_builddir='$(abs_top_builddir)' \
DBUS_PYTHON_NO_DEPRECATED=1 \
- $(PYTHON) -m sphinx -b html $(abs_top_srcdir)/doc doc/_build
+ $(PYTHON) -m sphinx -b html $(abs_top_srcdir)/doc doc/html
touch $@
-maintainer-update-website: doc/_build/.stamp
+maintainer-update-website: doc/html/.stamp
DBUS_TOP_SRCDIR="$(abs_top_srcdir)" \
$(PYTHON) $(srcdir)/doc/redirects.py
- rsync -rtvzPp --chmod=Dg+s,ug+rwX,o=rX doc/_build/ \
+ rsync -rtvzPp --chmod=Dg+s,ug+rwX,o=rX doc/html/ \
dbus.freedesktop.org:/srv/dbus.freedesktop.org/www/doc/dbus-python/
-install-data-local-sphinx: doc/_build/.stamp
+install-data-local-sphinx: doc/html/.stamp
$(mkinstalldirs) $(DESTDIR)$(htmldir)
- cp -R doc/_build/* $(DESTDIR)$(htmldir)
+ cp -R doc/html/* $(DESTDIR)$(htmldir)
uninstall-local-sphinx:
rm -fr $(DESTDIR)$(htmldir)
@@ -462,7 +471,7 @@ uninstall-local-sphinx:
endif
clean-local:
- rm -rf doc/_build
+ rm -rf doc/html
check_c_sources = \
$(_dbus_bindings_la_SOURCES) \