summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.j.ledkov@linux.intel.com>2015-08-31 23:05:01 +0100
committerDimitri John Ledkov <dimitri.j.ledkov@linux.intel.com>2015-08-31 23:05:01 +0100
commit72791df7a44409ea6e971587e95f7c21d38578f4 (patch)
tree76fabed08368c52a9b551b8a7920489dfaeead52
parentf589802f2992a2d0691caf8e3a4cc334f2289251 (diff)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/60_gcc5_compat.patch349
2 files changed, 356 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0f0608a..7c82d80 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dc-qt (0.2.0.alpha-4.3) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix FTBFS with gcc5.
+
+ -- Dimitri John Ledkov <dimitri.j.ledkov@linux.intel.com> Mon, 31 Aug 2015 23:04:39 +0100
+
dc-qt (0.2.0.alpha-4.2) unstable; urgency=low
* Non-maintainer upload.
diff --git a/debian/patches/60_gcc5_compat.patch b/debian/patches/60_gcc5_compat.patch
new file mode 100644
index 0000000..febb0d0
--- /dev/null
+++ b/debian/patches/60_gcc5_compat.patch
@@ -0,0 +1,349 @@
+diff --git a/backend/SessionManager.h b/backend/SessionManager.h
+index f2fcab4..6ee359f 100644
+--- a/backend/SessionManager.h
++++ b/backend/SessionManager.h
+@@ -18,7 +18,9 @@
+ #include <pthread.h>
+ #include "Stack.h"
+ #include <ext/hash_map>
++#ifndef Q_MOC_RUN
+ #include <boost/thread/recursive_mutex.hpp>
++#endif
+
+ namespace dcqt_backend {
+
+diff --git a/backend/SettingsMapper.h b/backend/SettingsMapper.h
+index 94273e8..098cd92 100644
+--- a/backend/SettingsMapper.h
++++ b/backend/SettingsMapper.h
+@@ -5,7 +5,9 @@
+ #include <dcpp/DCPlusPlus.h>
+ #include <dcpp/SettingsManager.h>
+ #include <map>
++#ifndef Q_MOC_RUN
+ #include <boost/any.hpp>
++#endif
+ using namespace std;
+
+ //! Maps settings between dc-qt and dc++ format, keys have same names but as strings.
+diff --git a/backend/log.h b/backend/log.h
+index b0acc5f..ef5b830 100644
+--- a/backend/log.h
++++ b/backend/log.h
+@@ -13,7 +13,9 @@
+ #define LOG_H__
+
+
++#ifndef Q_MOC_RUN
+ #include <boost/format.hpp>
++#endif
+ //! Logging interface
+ class Log
+ {
+diff --git a/dcpp/StringDefs.h b/dcpp/StringDefs.h
+index fb9b0dc..cc2cf61 100644
+--- a/dcpp/StringDefs.h
++++ b/dcpp/StringDefs.h
+@@ -485,7 +485,7 @@ enum Strings { // @DontAdd
+ SHARED, // "Shared"
+ SHARED_FILES, // "Shared Files"
+ SIZE, // "Size"
+- SIZE_MAX, // "Max Size"
++ SIZE_MAXIMUM, // "Max Size"
+ SIZE_MIN, // "Min Size"
+ SKIP_RENAME, // "New virtual name matches old name, skipping..."
+ SLOT_GRANTED, // "Slot granted"
+diff --git a/rpcdriver/commanddispatcher.h b/rpcdriver/commanddispatcher.h
+index f6a5f01..ca77377 100644
+--- a/rpcdriver/commanddispatcher.h
++++ b/rpcdriver/commanddispatcher.h
+@@ -3,11 +3,13 @@
+ #ifndef _COMMAND_DISPATCHER_H_
+ #define _COMMAND_DISPATCHER_H_
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
+ #include <boost/utility.hpp>
+ #include <boost/thread/mutex.hpp>
+ #include <boost/thread/condition.hpp>
+ #include <boost/any.hpp>
++#endif
+
+ #include <string>
+ #include <map>
+diff --git a/rpcdriver/datainputstream.h b/rpcdriver/datainputstream.h
+index 7649285..6b0e9d4 100644
+--- a/rpcdriver/datainputstream.h
++++ b/rpcdriver/datainputstream.h
+@@ -13,8 +13,9 @@
+ #define RPCDATAINPUTSTREAM_H
+
+ #include <string>
+-
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include "inputbuffer.h"
+ #include "types.h"
+diff --git a/rpcdriver/inputbuffer.h b/rpcdriver/inputbuffer.h
+index 77f8578..b7b22fd 100644
+--- a/rpcdriver/inputbuffer.h
++++ b/rpcdriver/inputbuffer.h
+@@ -12,9 +12,11 @@
+ #ifndef RPCINPUTBUFFER_H
+ #define RPCINPUTBUFFER_H
+
++#ifndef Q_MOC_RUN
+ #include <boost/scoped_array.hpp>
+ #include <boost/shared_ptr.hpp>
+ #include <boost/utility.hpp>
++#endif
+
+ namespace rpc
+ {
+diff --git a/rpcdriver/outputbuffer.h b/rpcdriver/outputbuffer.h
+index ca1d0bf..96bfbf1 100644
+--- a/rpcdriver/outputbuffer.h
++++ b/rpcdriver/outputbuffer.h
+@@ -4,7 +4,9 @@
+ #include <stdlib.h>
+ #include <iostream>
+ using namespace std;
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ namespace rpc {
+
+diff --git a/rpcdriver/protectedbuffer.h b/rpcdriver/protectedbuffer.h
+index e7f0dd0..0385c79 100644
+--- a/rpcdriver/protectedbuffer.h
++++ b/rpcdriver/protectedbuffer.h
+@@ -10,7 +10,9 @@
+ #ifndef _BUFFER_H_
+ #define _BUFFER_H_
+
++#ifndef Q_MOC_RUN
+ #include <boost/thread/mutex.hpp>
++#endif
+
+ #include <queue>
+ #include <stdexcept>
+diff --git a/rpcdriver/rpccommandhandler.h b/rpcdriver/rpccommandhandler.h
+index 8009e73..8ab89b1 100644
+--- a/rpcdriver/rpccommandhandler.h
++++ b/rpcdriver/rpccommandhandler.h
+@@ -9,10 +9,11 @@
+
+ #ifndef _RPC_COMMAND_H_
+ #define _RPC_COMMAND_H_
+-
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
+ #include <boost/any.hpp>
+ #include <boost/function.hpp>
++#endif
+
+ #include <string>
+ #include <list>
+diff --git a/rpcdriver/rpcdriver.h b/rpcdriver/rpcdriver.h
+index 289d09a..8120d24 100644
+--- a/rpcdriver/rpcdriver.h
++++ b/rpcdriver/rpcdriver.h
+@@ -2,11 +2,13 @@
+ #ifndef _RPC_DRIVER_H_
+ #define _RPC_DRIVER_H_
+
++#ifndef Q_MOC_RUN
+ #include <boost/utility.hpp>
+ #include <boost/shared_ptr.hpp>
+ #include <boost/thread/condition.hpp>
+ #include <boost/thread/mutex.hpp>
+ #include <boost/thread/thread.hpp>
++#endif
+
+ #include <queue>
+ #include <string>
+diff --git a/rpcdriver/types.h b/rpcdriver/types.h
+index f030264..230ab8c 100644
+--- a/rpcdriver/types.h
++++ b/rpcdriver/types.h
+@@ -1,6 +1,8 @@
+ #ifndef types_h__
+ #define types_h__
++#ifndef Q_MOC_RUN
+ #include <boost/cstdint.hpp>
++#endif
+ typedef boost::int64_t int64;
+ typedef int int32;
+ typedef short int16;
+diff --git a/ui/backendconnection.h b/ui/backendconnection.h
+index 37fafd2..45a0984 100644
+--- a/ui/backendconnection.h
++++ b/ui/backendconnection.h
+@@ -14,7 +14,9 @@
+ #include <QVariant>
+ #include <QPair>
+ #include "global.h"
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+ #include <rpcdriver.h>
+ #include "rpctypes.h"
+
+diff --git a/ui/commandhandlersinclude.h b/ui/commandhandlersinclude.h
+index 307107a..776e602 100644
+--- a/ui/commandhandlersinclude.h
++++ b/ui/commandhandlersinclude.h
+@@ -3,8 +3,10 @@
+
+ #include <list>
+ #include <algorithm>
++#ifndef Q_MOC_RUN
+ #include <boost/any.hpp>
+ #include <boost/function.hpp>
++#endif
+ #include "rpcdriver/rpccommandhandler.h"
+ #include "global.h"
+ #include "rpctypes.h"
+diff --git a/ui/favouritehubswidget.h b/ui/favouritehubswidget.h
+index b3a7c0f..e7a468c 100644
+--- a/ui/favouritehubswidget.h
++++ b/ui/favouritehubswidget.h
+@@ -11,7 +11,9 @@
+ #ifndef FAVOURITE_HUBS_H__
+ #define FAVOURITE_HUBS_H__
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include <QWidget>
+ #include <QAbstractTableModel>
+diff --git a/ui/global.h b/ui/global.h
+index 2dd769c..53c2040 100644
+--- a/ui/global.h
++++ b/ui/global.h
+@@ -2,7 +2,9 @@
+ #define GLOBAL_H__
+
+ #include <QtGlobal>
++#ifndef Q_MOC_RUN
+ #include <boost/any.hpp>
++#endif
+ #include <list>
+
+ //typedef qint64 int64;
+diff --git a/ui/mainwindow.cpp b/ui/mainwindow.cpp
+index a61302e..c2dff60 100644
+--- a/ui/mainwindow.cpp
++++ b/ui/mainwindow.cpp
+@@ -2,7 +2,9 @@
+ #include <QtGui>
+
+ #include <iostream>
++#ifndef Q_MOC_RUN
+ #include <boost/bind.hpp>
++#endif
+
+ #include "mainwindow.h"
+ #include "connectdialog.h"
+diff --git a/ui/mainwindow.h b/ui/mainwindow.h
+index cabf380..c18b71f 100644
+--- a/ui/mainwindow.h
++++ b/ui/mainwindow.h
+@@ -15,7 +15,9 @@
+
+ #include <QMainWindow>
+ #include <QPointer>
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+ #include <rpcdriver.h>
+
+ class ConnectDialog;
+diff --git a/ui/publichubswidget.h b/ui/publichubswidget.h
+index af44004..93456ce 100644
+--- a/ui/publichubswidget.h
++++ b/ui/publichubswidget.h
+@@ -6,7 +6,9 @@
+ *
+ */
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include <QWidget>
+ #include <QAbstractTableModel>
+diff --git a/ui/queuemodel.h b/ui/queuemodel.h
+index eaec780..ffe86b3 100644
+--- a/ui/queuemodel.h
++++ b/ui/queuemodel.h
+@@ -10,7 +10,9 @@
+ #include <QList>
+ #include "queueitem.h"
+ #include "globalusermodel.h"
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ //! Transfer queue data model.
+ class QueueModel : public QAbstractTableModel
+diff --git a/ui/session.h b/ui/session.h
+index c276a6c..339c3cf 100644
+--- a/ui/session.h
++++ b/ui/session.h
+@@ -12,7 +12,9 @@
+ #ifndef SESSION_H
+ #define SESSION_H
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include <QWidget>
+ #include "ui_hub.h"
+diff --git a/ui/settingsdialog.h b/ui/settingsdialog.h
+index f64aff8..afa93be 100644
+--- a/ui/settingsdialog.h
++++ b/ui/settingsdialog.h
+@@ -13,7 +13,9 @@
+ #define SETTINGSDIALOG_H
+
+ #include <QDialog>
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+ #include "ui_settings.h"
+ #include "backendconnection.h"
+ #include "shareitemmodel.h"
+diff --git a/ui/userfiledialog.h b/ui/userfiledialog.h
+index 9fa001f..efceddf 100644
+--- a/ui/userfiledialog.h
++++ b/ui/userfiledialog.h
+@@ -11,7 +11,9 @@
+ #ifndef USER_FILE_DIALOG_H
+ #define USER_FILE_DIALOG_H
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include <QDialog>
+
+diff --git a/ui/userfilemodel.h b/ui/userfilemodel.h
+index 767c146..f8aa443 100644
+--- a/ui/userfilemodel.h
++++ b/ui/userfilemodel.h
+@@ -13,7 +13,9 @@
+ #ifndef USER_FILE_TREE_MODEL_H_
+ #define USER_FILE_TREE_MODEL_H_
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
++#endif
+
+ #include <QtGui>
+ #include <QAbstractItemModel>