summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-10 15:37:36 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 15:37:36 -0400
commit877c62f70a904c1f549fbee9f763345bc19c6697 (patch)
treecf784a0e12027d46a4e1ea8f7deed04b4f3540e8
parentf2c0117a7d1585401dea0cad7a23b59c3b311681 (diff)
dh_desktop: Now a deprecated no-op, since desktop-file-utils uses triggers. Closes: #523474 (also Closes: #521960, #407701 as no longer applicable)
-rw-r--r--autoscripts/postinst-desktop3
-rw-r--r--autoscripts/postrm-desktop3
-rw-r--r--debian/changelog6
-rwxr-xr-xdh1
-rwxr-xr-xdh_desktop28
5 files changed, 7 insertions, 34 deletions
diff --git a/autoscripts/postinst-desktop b/autoscripts/postinst-desktop
deleted file mode 100644
index ff6e6a12..00000000
--- a/autoscripts/postinst-desktop
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ "$1" = "configure" ] && which update-desktop-database >/dev/null 2>&1 ; then
- update-desktop-database -q
-fi
diff --git a/autoscripts/postrm-desktop b/autoscripts/postrm-desktop
deleted file mode 100644
index 38dd191c..00000000
--- a/autoscripts/postrm-desktop
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ "$1" = "remove" ] && which update-desktop-database >/dev/null 2>&1 ; then
- update-desktop-database -q
-fi
diff --git a/debian/changelog b/debian/changelog
index 2ad788b6..5321bdba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,8 @@
debhelper (7.2.8) UNRELEASED; urgency=low
- * dh_desktop: Avoid using find -execdir as it will fail
- with certian badly configured PATHs (and is not a benefit
- in this context anyway). Closes: #521960
+ * dh_desktop: Now a deprecated no-op, since desktop-file-utils
+ uses triggers. Closes: #523474
+ (also Closes: #521960, #407701 as no longer applicable)
-- Joey Hess <joeyh@debian.org> Tue, 31 Mar 2009 14:07:13 -0400
diff --git a/dh b/dh
index f557a633..6ac495a2 100755
--- a/dh
+++ b/dh
@@ -251,7 +251,6 @@ $sequences{install} = [@{$sequences{build}}, qw{
dh_installxfonts
dh_bugfiles
dh_lintian
- dh_desktop
dh_gconf
dh_icons
dh_perl
diff --git a/dh_desktop b/dh_desktop
index 79001523..6fb7d021 100755
--- a/dh_desktop
+++ b/dh_desktop
@@ -2,7 +2,7 @@
=head1 NAME
-dh_desktop - Register .desktop files
+dh_desktop - deprecated no-op
=cut
@@ -15,34 +15,14 @@ B<dh_desktop> [S<I<debhelper options>>]
=head1 DESCRIPTION
-dh_desktop is a debhelper program that registers .desktop files.
-Currently this program does not handle installation of the files, though it
-may do so at a later date. It takes care of adding maintainer script
-fragments to call F<update-desktop-database>.
-
-Note that since F<update-desktop-database> currently only handles mime
-types, as an optimisation, desktop files not containing MimeType fields
-will currently be ignored by dh_desktop.
+dh_desktop was a debhelper program that registers .desktop files.
+However, it no longer does anything, and is now deprecated.
=cut
init();
-foreach my $package (@{$dh{DOPACKAGES}}) {
- my $tmp=tmpdir($package);
-
- if (-d "$tmp/usr/share/applications") {
- # Get a list of the desktop files that are in
- # usr/share/applications and thus might need
- # update-desktop-database be called. Other desktop
- # files don't.
- my $desktop_files = `find $tmp/usr/share/applications -type f -name \\*.desktop -exec grep -q "^MimeType" '{}' \\; -printf '%p\n'`;
- if ($desktop_files && ! $dh{NOSCRIPTS}) {
- autoscript($package,"postinst","postinst-desktop");
- autoscript($package,"postrm","postrm-desktop");
- }
- }
-}
+warning("This program is deprecated, and does nothing anymore.");
=head1 SEE ALSO