summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-01-06 04:58:07 +0000
committerjoey <joey>2002-01-06 04:58:07 +0000
commit07659546d4248d4f4f4edc2c03d2ca5a6fe32f02 (patch)
tree74f1d6681492ef390ea04f1a4e0b255a3ec61785
parentf4bfda706202d3136b6475cf0680674172ddf4f1 (diff)
r501: * Began work on v4 support (and thus the large version number jump), and it
is only for the very brave right now since I will unhesitatingly break compatability in v4 mode as I'm developing it. Currently, updating to v4 mode will only make dh_makeshlibs -V generate shared library deps that omit the debian part of the version number. The reasoning behind this change is that the debian revision should not typically break binary compatability, that existing use of -V is causing too tight versioned deps, and that if you do need to include the debian revision for some reason, you can always write it out by hand. Closes: #101497 * dh_testversion is deprecated -- use build deps instead. A warning message is now output when it runs. Currently used by: 381 packages. * dh_installxaw is deprecated -- xaw-wrappers in no longer in the distribution. A warning message is now output when it runs. Currently used by: 3 packages (bugs filed). * Added referneces to menufile in dh_installmenu man page. Closes: #127978 (dh_make is not a part of debhelper, if you want it changed, file a bug on dh-make.)
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debhelper.pod14
-rw-r--r--debian/changelog22
-rwxr-xr-xdh_installmenu4
-rwxr-xr-xdh_installxaw5
-rwxr-xr-xdh_makeshlibs9
-rwxr-xr-xdh_testversion3
-rw-r--r--doc/TODO27
8 files changed, 75 insertions, 11 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 588ea063..f5a376fd 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -14,7 +14,7 @@ use vars qw(@ISA @EXPORT %dh);
&pkgfile &pkgext &isnative &autoscript &filearray &GetPackages
&basename &dirname &xargs %dh &compat);
-my $max_compat=3;
+my $max_compat=4;
sub init {
# If DH_OPTIONS is set, prepend it @ARGV.
diff --git a/debhelper.pod b/debhelper.pod
index 82ced753..535d4772 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -241,6 +241,20 @@ Every file in etc/ is automatically flagged as a conffile by dh_installdeb.
=back
+=item V4
+
+This mode is still under development, and its behavior may change at any
+time. Currently, setting DH_COMPAT=4 does everything V4 does, plus:
+
+=over 8
+
+=item -
+
+dh_makeshlibs -V will not include the debian part of the version number in
+the generated dependancy line in the shlibs file.
+
+=back
+
=back
=head2 Doc directory symlinks
diff --git a/debian/changelog b/debian/changelog
index eebddb3b..d1a36af8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,25 @@
+debhelper (3.4.0) unstable; urgency=low
+
+ * Began work on v4 support (and thus the large version number jump), and it
+ is only for the very brave right now since I will unhesitatingly break
+ compatability in v4 mode as I'm developing it. Currently, updating to v4
+ mode will only make dh_makeshlibs -V generate shared library deps that
+ omit the debian part of the version number. The reasoning behind this
+ change is that the debian revision should not typically break binary
+ compatability, that existing use of -V is causing too tight versioned
+ deps, and that if you do need to include the debian revision for some
+ reason, you can always write it out by hand. Closes: #101497
+ * dh_testversion is deprecated -- use build deps instead. A warning message
+ is now output when it runs. Currently used by: 381 packages.
+ * dh_installxaw is deprecated -- xaw-wrappers in no longer in the
+ distribution. A warning message is now output when it runs. Currently used
+ by: 3 packages (bugs filed).
+ * Added referneces to menufile in dh_installmenu man page. Closes: #127978
+ (dh_make is not a part of debhelper, if you want it changed, file a bug on
+ dh-make.)
+
+ -- Joey Hess <joeyh@debian.org> Sat, 5 Jan 2002 22:45:09 -0500
+
debhelper (3.0.54) unstable; urgency=low
* Added a version to the perl build dep, Closes: #126677
diff --git a/dh_installmenu b/dh_installmenu
index 522f6269..212423c4 100755
--- a/dh_installmenu
+++ b/dh_installmenu
@@ -24,7 +24,7 @@ explanation of how this works.
If a file named debian/package.menu exists, then it is installed into
usr/lib/menu/package in the package build directory. This is a debian menu
-file.
+file. See L<menufile(5L)> for its format.
If a file named debian/package.menu-method exits, then it is installed into
etc/menu-methods/package in the package build directory. This is a debian
@@ -79,6 +79,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
=head1 SEE ALSO
L<debhelper(1)>
+L<update-menus(1)>
+L<menufile(5L)>
This program is a part of debhelper.
diff --git a/dh_installxaw b/dh_installxaw
index fed5f2d4..17321834 100755
--- a/dh_installxaw
+++ b/dh_installxaw
@@ -15,6 +15,9 @@ B<dh_installxaw> [S<I<debhelper options>>] [B<-n>]
=head1 DESCRIPTION
+Warning: The xaw-wrappers package has been removed from debian, and so this
+program is deprecated, and due to be removed soon.
+
dh_installxaw is a debhelper program that is responsible for installing
xaw wrappers config files into package build directories.
@@ -45,6 +48,8 @@ instances of the same text to be added to maintainer scripts.
init();
+warning("The xaw-wrappers package has been removed from debian, and so this program is deprecated, and due to be removed soon.");
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $xaw=pkgfile($package,'xaw');
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 8f0045a8..478c861b 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -136,7 +136,14 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Call isnative becuase it sets $dh{VERSION}
# as a side effect.
isnative($package);
- $deps="$package (>= $dh{VERSION})";
+ my $version = $dh{VERSION};
+ # Old compatability levels include the
+ # debian revision, while new do not.
+ if (! compat(3)) {
+ # Remove debian version, if any.
+ $version =~ s/-[^-]+$//;
+ }
+ $deps="$package (>= $version)";
}
}
if (defined($library) && defined($major) && defined($deps) &&
diff --git a/dh_testversion b/dh_testversion
index b915dd14..e7fbfec9 100755
--- a/dh_testversion
+++ b/dh_testversion
@@ -63,7 +63,10 @@ elsif ($#ARGV eq 0) {
$ver=shift;
}
+warning("This program is deprecated, you should use build dependencies instead.");
+
if (defined $compare and defined $ver) {
+ warning("Something like: \"Build-Depends: debhelper ($compare $ver)\"");
system('dpkg','--compare-versions',$Debian::Debhelper::Dh_Version::version,$compare,$ver) == 0 ||
error("debhelper version $Debian::Debhelper::Dh_Version::version is installed, but a version $compare $ver is needed to build this package.");
}
diff --git a/doc/TODO b/doc/TODO
index bc1b6d50..2b1e3030 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -53,21 +53,32 @@ Wishlist items:
* Add a switch to dh_installdeb to allow it to do user defined
substitutions. OTOH, maybe it's better if people just sed
postinst.in before debhelper gets it's hands on it... (#25235)
+* dh_installdocs needs -X support, which probably means going with tar
+ instead of cp -a. Ugh.
+
+v4:
+
+These items are part of v4 already:
+
+* dhmakeshlibs -V omits the debian part of the version number from the
+ generated dependancy in the shlibs file
+
+These items are planned:
+
+* Maybe make dh_fixperms make all files in bin/ dirs +x. (#119039)
Deprecated:
* DH_COMPAT 1. Can be removed once all packages are seen to be using 2 or
higher. I won't hold my breath.
-* Also, grep the entire archive for all dh_* command lines, and check to
- see what other switches are not being used, and maybe remove some of
- them. I'd also like to depercate/remove debian/compress files, -X is
+* Also, grep the entire archive for all dh_* command lines (I do this now),
+ and check to see what other switches are not being used, and maybe remove
+ some of them. I'd also like to depercate/remove debian/compress files, -X is
a better idea.
* dh_suidregister. Once nothing in the archive uses it.
* dh_installmanpages. Only mildly deprecated right now. Once dh_installman
catches on, make it emit a warning, and then wait for it to go away.
-* dh_testversion. Only mildly deprecated right now. Make it emit a warning
- by jan 2002, and remove as soon as nothing uses it.
+* dh_testversion. Remove as soon as nothing uses it.
* dh_installxaw. xaw replacments are dying, nothing uses it validly (bugs
- filed on the few packages that use it by accident). Make it omit a
- warning by jan 2002 and remove as soon as nothing uses it, or by april
- 2002.
+ filed on the few packages that use it by accident). Remove as soon as
+ nothing uses it, or by april 2002.