summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2010-03-31 15:58:54 -0400
committerJoey Hess <joey@gnu.kitenet.net>2010-03-31 15:58:54 -0400
commit2380e46415865dc654e2b8056aa85b893f4b93fb (patch)
tree82cfc89bd33656493229cfd67c13dfc508b3c477
parent38643554bf86b8d1b63632e37d9865bd33891a4b (diff)
dh_md5sums: Sort to ensure stable, more diffable order. Closes: #573702
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_md5sums2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c44632ff..358282e4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,7 @@ debhelper (7.4.16) UNRELEASED; urgency=low
can efficiently be changed to the more sane default of acting on only
packages that can be built for the current architecture. This change
is mostly useful when using minimal rules files with dh. Closes: #572077
+ * dh_md5sums: Sort to ensure stable, more diffable order. Closes: #573702
-- Joey Hess <joeyh@debian.org> Thu, 18 Feb 2010 17:53:27 -0500
diff --git a/dh_md5sums b/dh_md5sums
index da00090b..ba1adf4f 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -75,7 +75,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$exclude.="! \\( $dh{EXCLUDE_FIND} \\) ";
}
- complex_doit("(cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums) >/dev/null");
+ complex_doit("(cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums) >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {
doit("rm","-f","$tmp/DEBIAN/md5sums");