summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-09-16 17:39:33 +0000
committerjoey <joey>2002-09-16 17:39:33 +0000
commit3605d515acc588025eab1f32b159a961bf0773bb (patch)
tree78c52b905e26c49905cbb1a98f8d42e0a8c6eead
parent06eac1b429eff2ff995cc738dd64e449b757d6d3 (diff)
r549: * Fixed over-escaping of period when generating EXCLUDE_FIND.
Closes: #159155
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog7
2 files changed, 8 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 3bf7df18..e2d26b25 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -54,7 +54,7 @@ sub init {
foreach (@{$dh{EXCLUDE}}) {
my $x=$_;
$x=escape_shell($x);
- $x=~s/\./\\\\./g;
+ $x=~s/\./\\./g;
$dh{EXCLUDE_FIND}.="-regex .*$x.* -or ";
}
$dh{EXCLUDE_FIND}=~s/ -or $//;
diff --git a/debian/changelog b/debian/changelog
index 0e4bd9c0..2bb00ace 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.9) unstable; urgency=low
+
+ * Fixed over-escaping of period when generating EXCLUDE_FIND.
+ Closes: #159155
+
+ -- Joey Hess <joeyh@debian.org> Mon, 16 Sep 2002 13:41:05 -0400
+
debhelper (4.1.8) unstable; urgency=low
* Use invoke-rc.d always now that it is in policy. Fall back to old behavior