summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2004-12-09 19:33:18 +0000
committerjoey <joey>2004-12-09 19:33:18 +0000
commit6312eb3129e31d18dcced1074fe7282201616097 (patch)
treebe6fde8ff7739b6c33329025e9c62aaf911ff185
parent0a9afa6c5a1d57d596aa07d32052661ff146d3bf (diff)
r1730: releasing version 4.2.27
-rw-r--r--debian/changelog7
-rw-r--r--dh_desktop2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 67ebbd11..9d9f4659 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.2.27) unstable; urgency=low
+
+ * dh_desktop: Fix underescaping of *.desktop in call to find.
+ Closes: #284832
+
+ -- Joey Hess <joeyh@debian.org> Thu, 9 Dec 2004 14:32:41 -0500
+
debhelper (4.2.26) unstable; urgency=low
* dh_makeshlibs spanish translation update
diff --git a/dh_desktop b/dh_desktop
index 20346061..29970e45 100644
--- a/dh_desktop
+++ b/dh_desktop
@@ -32,7 +32,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# usr/share/applications and thus might need
# update-desktop-database be called. Other desktop
# files don't.
- my $desktop_files = `find $tmp/usr/share/applications -type f -name \*.desktop -printf '%p\n'`;
+ my $desktop_files = `find $tmp/usr/share/applications -type f -name \\*.desktop -printf '%p\n'`;
if ($desktop_files && ! $dh{NOSCRIPTS}) {
autoscript($package,"postinst","postinst-desktop");
autoscript($package,"postrm","postrm-desktop");