summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-03-15 21:12:51 +0000
committerjoeyh <joeyh>2006-03-15 21:12:51 +0000
commit104c724c4ac5172367bea345e5b500ce45dcf0cf (patch)
treed1651ce04aacf43a2629ddea323663ff3d172ac3
parent5b3da8f1752c6123c3a253821555fb50aee4deab (diff)
r1885: * dh_installdebconf: For udebs, misc:Depends will now contain cdebconf-udeb.
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installdebconf4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e9e82aa..df72a8f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (5.0.25) UNRELEASED; urgency=low
+
+ * dh_installdebconf: For udebs, misc:Depends will now contain cdebconf-udeb.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 15 Mar 2006 16:12:20 -0500
+
debhelper (5.0.24) unstable; urgency=low
[ Joey Hess ]
diff --git a/dh_installdebconf b/dh_installdebconf
index b1a23453..c25a7795 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -100,8 +100,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# I'm going with debconf 0.5 because it was the first
- # "modern" one.
- my $debconfdep="debconf (>= 0.5) | debconf-2.0";
+ # "modern" one. udebs just need cdebconf.
+ my $debconfdep=is_udeb($package) ? "cdebconf-udeb" : "debconf (>= 0.5) | debconf-2.0";
if ($config ne '' || $templates ne '') {
addsubstvar($package, "misc:Depends", $debconfdep);
}