summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-01-27 04:21:56 +0000
committerjoey <joey>2002-01-27 04:21:56 +0000
commit26fc54549b83f4efd2db161b86159dd65da974a9 (patch)
treeb24bcd750f9358c7c6f3013471140197660bb696
parentd99c84bf7e7da25e096b3ce638627c3540a53a34 (diff)
r505: * Improved dh_installxfonts some more:
- Better indenting of generated code. - Better ordering of generated code (minor fix).
-rw-r--r--autoscripts/postinst-xfonts2
-rw-r--r--autoscripts/postrm-xfonts2
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_installxfonts8
4 files changed, 14 insertions, 6 deletions
diff --git a/autoscripts/postinst-xfonts b/autoscripts/postinst-xfonts
index 4c5ab1b8..8821bc5f 100644
--- a/autoscripts/postinst-xfonts
+++ b/autoscripts/postinst-xfonts
@@ -1,3 +1,3 @@
if [ -x /usr/sbin/update-fonts-dir ]; then
- #CMDS#
+#CMDS#
fi
diff --git a/autoscripts/postrm-xfonts b/autoscripts/postrm-xfonts
index a9afcabe..b5dd964b 100644
--- a/autoscripts/postrm-xfonts
+++ b/autoscripts/postrm-xfonts
@@ -1,3 +1,3 @@
if [ "$1" != "upgrade" -a -x /usr/sbin/update-fonts-dir ]; then
- #CMDS#
+#CMDS#
fi
diff --git a/debian/changelog b/debian/changelog
index ebe4eef3..93653398 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.4.3) unstable; urgency=low
+
+ * Improved dh_installxfonts some more:
+ - Better indenting of generated code.
+ - Better ordering of generated code (minor fix).
+
+ -- Joey Hess <joeyh@debian.org> Sat, 26 Jan 2002 23:09:59 -0500
+
debhelper (3.4.2) unstable; urgency=low
* dh_installman: more documentation about the .TH line. Closes: #129205
diff --git a/dh_installxfonts b/dh_installxfonts
index f8d9d469..fb7f7fee 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -58,16 +58,16 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# to call.
my @cmds;
foreach my $f (@fontdirs) {
+ # This must come before update-fonts-dir.
+ push @cmds, "update-fonts-scale $f"
+ if -f "$tmp/etc/X11/fonts/$f/$package.scale";
push @cmds, "update-fonts-dir $f";
push @cmds, "update-fonts-alias $f"
if -f "$tmp/etc/X11/fonts/$f/$package.alias";
- # This must come _before_ mkfontdir, thus the unshift.
- unshift @cmds, "update-fonts-scale $f"
- if -f "$tmp/etc/X11/fonts/$f/$package.scale";
}
autoscript($package, "postinst", "postinst-xfonts",
- "s:#CMDS#:".join("\n", @cmds).":;");
+ "s:#CMDS#:".join("\n", map { "\t$_" } @cmds).":;");
autoscript($package, "postrm", "postrm-xfonts",
"s:#CMDS#:".join("\n", @cmds).":;");
}