summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-28 16:00:36 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-28 16:00:36 -0400
commit0ebb1c696b8e5617a348976abcb3858e47e1df01 (patch)
treef2e922f835d2d3537d6aa15776a3b601adafb797
parenta7a4b118fa290eb38be206c4c01a8f433c4f8f14 (diff)
dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps prints a confusing warning if it does not. Closes: #534226
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps5
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0e3b9428..a82d4c62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.18) UNRELEASED; urgency=low
+
+ * dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps
+ prints a confusing warning if it does not. Closes: #534226
+
+ -- Joey Hess <joeyh@debian.org> Sun, 28 Jun 2009 15:59:11 -0400
+
debhelper (7.2.17) unstable; urgency=low
* Allow command-specific options to be passed to commands
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 3ab89818..e5f73cba 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -112,6 +112,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $ext=pkgext($package);
+ # dpkg-shlibdeps expects this directory to exist
+ if (! -d "$tmp/DEBIAN") {
+ doit("install","-o",0,"-g",0,"-d","$tmp/DEBIAN");
+ }
+
my @filelist;
my $ff;