summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-14 16:36:13 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-07-14 16:36:13 -0400
commit1681cb48a6cb9f33de3fc2da5b62ace493dde79a (patch)
treed8c9ab7ffc641ae5608f3c19491b8ee787ec7d1d
parent278e416302f4389b3bfbdc68998edfeee4decc26 (diff)
Add ant buildsystem support. Closes: #537021
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm1
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_auto_install3
3 files changed, 9 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index a9a6b914..4bac6a12 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -23,6 +23,7 @@ our @BUILDSYSTEMS = (
"python_distutils",
"perl_build",
"cmake",
+ "ant",
);
my $opt_buildsys;
diff --git a/debian/changelog b/debian/changelog
index a9360b76..b68e6d24 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.3.3) UNRELEASED; urgency=low
+
+ * Add ant buildsystem support. Closes: #537021
+
+ -- Joey Hess <joeyh@debian.org> Tue, 14 Jul 2009 16:35:50 -0400
+
debhelper (7.3.2) experimental; urgency=low
* Merged debhelper 7.2.21.
diff --git a/dh_auto_install b/dh_auto_install
index 2e2aa214..b57db839 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -22,7 +22,8 @@ built files. It does so by running the appropriate command for the build
system it detects the package uses. For example, if there's a Makefile and
it contains a "install" target, then this is done by running make (or MAKE,
if the environment variable is set). If there is a setup.py or Build.PL,
-it is used.
+it is used. Note that the Ant build system does not support installation,
+so dh_auto_install will not install files built using Ant.
The files are installed into debian/<package>/ if there is only one binary
package. In the multiple binary package case, the files are instead