summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-05-28 15:17:50 -0400
committerJoey Hess <joey@kitenet.net>2010-05-28 15:17:50 -0400
commit3b22d8325c0bbbe490315c372e60ef60ef5b5bd1 (patch)
tree018951ea8ca61c511a0767cb1ebc00bb071aef0f
parent1b399c04b40bc6f0fac4aa218a76c9a7132e7e71 (diff)
parent93a73a7ead5d90accb7259a46efdebab113e6550 (diff)
Merge commit '93a73a7ead5d90accb7259a46efdebab113e6550'
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm3
-rw-r--r--debhelper.pod4
-rw-r--r--debian/changelog20
-rw-r--r--doc/TODO6
4 files changed, 18 insertions, 15 deletions
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index a14ff037..22f80f9e 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -20,10 +20,11 @@ use constant BUILD_STEPS => qw(configure build test install clean);
# build systems MUST be added to the END of the list.
our @BUILDSYSTEMS = (
"autoconf",
+ (! compat(7) ? "perl_build" : ()),
"perl_makemaker",
"makefile",
"python_distutils",
- "perl_build",
+ (compat(7) ? "perl_build" : ()),
"cmake",
"ant",
"qmake",
diff --git a/debhelper.pod b/debhelper.pod
index a7735b1f..554b7f78 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -531,6 +531,10 @@ can cause some packages to fail to build.
dh requires the sequence to run be specified as the first parameter, and
any switches come after it. Ie, use "dh $@ --foo", not "dh --foo $@"
+=item
+
+dh_auto_* prefer to use perl's Module::Build in preference to Makefile.PL.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 5df9e2c9..a630fcd3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,15 @@ debhelper (7.9.1) UNRELEASED; urgency=low
target is not present in the same binary package, on advice of
Colin Watson. (To support eventual so search paths.)
* Add deprecation warning for dh_clean -k.
+ * dh_testversion: Removed this deprecated and unused command.
+ * debian/compress files are now deprecated. Seems only one package
+ (genesis) still uses them.
+ * dh_fixperms: Tighten globs used to find library .so files,
+ avoiding incorrectly matching things like "foo.sources". Closes: #583328
+ * dh_installchangelogs: Support packages placing their changelog in a
+ file with a name like HISTORY. Closes: #582749
+ * dh_installchangelogs: Also look for changelog files in doc(s)
+ subdirectories. Closes: #521258
* In v8 mode, do not allow directly passing unknown options to debhelper
commands. (Unknown options in DH_OPTIONS still only result in warnings.)
* In v8 mode, dh_makeshlibs will run dpkg-gensymbols on all shared
@@ -13,19 +22,12 @@ debhelper (7.9.1) UNRELEASED; urgency=low
means that libraries in unusual locations, where dpkg-gensymbols does
not itself normally look, will be passed to it, a behavior change which
may break some packages. Closes: #557603
- * dh_testversion: Removed this deprecated and unused command.
- * debian/compress files are now deprecated. Seems only one package
- (genesis) still uses them.
- * dh_fixperms: Tighten globs used to find library .so files,
- avoiding incorrectly matching things like "foo.sources". Closes: #583328
* In v8 mode, dh expects the sequence to run is always its first parameter.
(Ie, use "dh $@ --foo", not "dh --foo $@")
This avoids ambiguities when parsing options to be passed on to debhelper
commands. (See #570039)
- * dh_installchangelogs: Support packages placing their changelog in a
- file with a name like HISTORY. Closes: #582749
- * dh_installchangelogs: Also look for changelog files in doc(s)
- subdirectories. Closes: #521258
+ * In v8 mode, prefer the perl_build buildsystem over perl_makemaker.
+ Closes: #578805
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/doc/TODO b/doc/TODO
index 1f500806..346f1977 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -1,11 +1,8 @@
v8:
-* better package arch filtering for -N , -p (#576990)
* Support DEB_BUILD_OPTIONS=debug ; maybe also support passing
-g -O2 by default. See patch (and discussion of why this breaks
compatability) in #544844.
-* Reorder build systems list. perl_build before perl_makemaker.
- Any other changes? #578805
v9:
@@ -15,8 +12,7 @@ v9:
Deprecated:
* DH_COMPAT 1, 2, 3, 4. Can be removed once all packages are seen to be using
- a newer version. I won't hold my breath. Now with evil warning messages
- though.
+ a newer version. I won't hold my breath. (2 and 3 are getting close though.)
* dh_suidregister. Once nothing in the archive uses it.
* dh_installmanpages.
* dh_movefiles. I won't hold my breath. Have not added deprecation