summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2010-01-30 20:22:58 -0500
committerJoey Hess <joey@gnu.kitenet.net>2010-01-30 20:22:58 -0500
commit3ea2e2358ded1a7aa9a7eb1f6a69d3951f68d3fb (patch)
tree7d11366e1946a4f5971d110660a98bb313d22be4
parent75e1bc3ca1b20ad4512775e4b63b835d23cb2560 (diff)
Fix typo in call to abs2rel in --builddir sanitize code. Closes: #567737
-rw-r--r--Debian/Debhelper/Buildsystem.pm2
-rw-r--r--debian/changelog2
2 files changed, 3 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem.pm b/Debian/Debhelper/Buildsystem.pm
index f729c0da..88aefab3 100644
--- a/Debian/Debhelper/Buildsystem.pm
+++ b/Debian/Debhelper/Buildsystem.pm
@@ -96,7 +96,7 @@ sub _set_builddir {
$builddir = File::Spec->catdir($this->{cwd}, $builddir);
}
elsif ($builddir =~ /\Q$this->{cwd}\E/) {
- $builddir = File::Spec::abs2rel($builddir, $this->{cwd});
+ $builddir = File::Spec->abs2rel($builddir, $this->{cwd});
}
# If build directory ends up the same as source directory, drop it
diff --git a/debian/changelog b/debian/changelog
index 7858a5d6..51a4ac00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ debhelper (7.4.12) UNRELEASED; urgency=low
that do not support -B would see a bogus -u option. Closes: #541773
(It also ensures that the commands dh prints out can really be run.)
* qmake: New buildsystem contributed by Kel Modderman. Closes: #566840
+ * Fix typo in call to abs2rel in --builddir sanitize code.
+ Closes: #567737
-- Joey Hess <joeyh@debian.org> Fri, 01 Jan 2010 13:00:22 -0500