summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-26 15:20:42 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-03-26 15:20:42 -0400
commit42ee9ee542de3227ef426804db6b2cb19dbe8311 (patch)
treedf55c8347870ba5d24cb5623f84c2c842e8b9263
parentb54fc57aca3e1fed6c48dce22ebef37e1c49111a (diff)
dh_icons: ignore gnome and hicolor themes (will be handled by triggers). Closes: #521181
-rw-r--r--debian/changelog11
-rwxr-xr-xdh_icons2
2 files changed, 11 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5c8f1580..5351981a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,11 @@
-debhelper (7.2.7) UNRELEASED; urgency=low
+debhelper (7.2.8) UNRELEASED; urgency=low
+
+ * dh_icons: ignore gnome and hicolor themes (will be handled
+ by triggers). Closes: #521181
+
+ -- Joey Hess <joeyh@debian.org> Thu, 26 Mar 2009 15:20:07 -0400
+
+debhelper (7.2.7) unstable; urgency=low
* Fix calling the same helper for separate packages in the override of dh
binary-indep/binary-arch. Closes: #520567
@@ -6,7 +13,7 @@ debhelper (7.2.7) UNRELEASED; urgency=low
Closes: #520615
* Pass -L UTF-8 to po4a to work around bug #520942
- -- Joey Hess <joeyh@debian.org> Fri, 20 Mar 2009 21:26:03 -0400
+ -- Joey Hess <joeyh@debian.org> Mon, 23 Mar 2009 15:37:21 -0400
debhelper (7.2.6) unstable; urgency=low
diff --git a/dh_icons b/dh_icons
index 835287a8..4afbf7c0 100755
--- a/dh_icons
+++ b/dh_icons
@@ -46,6 +46,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
opendir(DIRHANDLE, $icondir);
while (my $subdir = readdir(DIRHANDLE)) {
next if $subdir =~ /^\./;
+ next if $subdir eq "gnome";
+ next if $subdir eq "hicolor";
my $needs_cache = 0;
find sub {
$needs_cache = 1 if -f and (/\.png$/ or /\.svg$/ or /\.xpm$/ or /\.icon$/);