summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 23:12:49 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 23:12:49 -0400
commit57834b0010aa942681c289e01ffc09030ed17ce2 (patch)
treebdb2e2fd1c4229bbb1fb898cda7eb971bd183a06
parent78425c5f80b3244439b3a9da130eb3602aa2dba2 (diff)
dh_clean: In v7 mode, automatically delete *-stamp files.
-rw-r--r--debhelper.pod4
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_clean6
3 files changed, 11 insertions, 2 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 480db344..f81234d0 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -407,6 +407,10 @@ parameters.
dh_clean will read debian/clean and delete files listed there.
+=item -
+
+dh_clean will delete toplevel *-stamp files.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 6b91af5d..f67c35fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,7 +18,7 @@ debhelper (7.0.0) UNRELEASED; urgency=low
setup.py to install. Supports the PREFIX=/usr special case needed by
MakeMaker Makefiles. (Support for cmake and other build systems planned
but not yet implemented.)
- * New v7 mode, which only has two changes from v6, and is the new
+ * New v7 mode, which only has three changes from v6, and is the new
recommended default, especially when using dh.
* dh_install: In v7 mode, if --sourcedir is not specified, first look for
files in debian/tmp, and then will look in the current directory. This
@@ -26,6 +26,7 @@ debhelper (7.0.0) UNRELEASED; urgency=low
special parameters.
* dh_clean: In v7 mode, read debian/clean and delete all files listed
therein.
+ * dh_clean: In v7 mode, automatically delete *-stamp files.
* Add a Makefile and simplify this package's own rules file using
all the new toys.
* dh_clean: Don't delete core dumps. (Too DWIM, and "core" is not
diff --git a/dh_clean b/dh_clean
index 78e43c36..2ef3ba38 100755
--- a/dh_clean
+++ b/dh_clean
@@ -20,7 +20,7 @@ package is built. It removes the package build directories, and removes some
other files including debian/files, and any detritus left behind by other
debhelper commands. It also removes common files that should not appear in a
debian diff:
- #*# *~ DEADJOE *.orig *.rej *.SUMS TAGS .deps/* *.P
+ #*# *~ DEADJOE *.orig *.rej *.SUMS TAGS .deps/* *.P *-stamp
It does not run "make clean" to clean up after the build process. Use
L<dh_auto_clean(1)> to do that.
@@ -119,6 +119,10 @@ if (! $dh{D_FLAG}) {
doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1) &&
! excludefile("debian/tmp");
+if (!compat(6)) {
+ complex_doit('rm -f *-stamp');
+}
+
=head1 SEE ALSO
L<debhelper(7)>