summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-30 20:24:46 +0000
committerjoey <joey>2001-05-30 20:24:46 +0000
commit5e4b47dc3e23c862f7af2428fcade51acbfb9b69 (patch)
treec13b2aa626eadbb736833a3e81775dee354c04cc
parenta524668098e5215a64ac4cc466b3de6590d13cfe (diff)
r473: * dh_clean: clean up temp files used by earlier versons of debhelper.
Closes: #99169
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_clean9
2 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 588dc726..5d9e2950 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.28) unstable; urgency=low
+
+ * dh_clean: clean up temp files used by earlier versons of debhelper.
+ Closes: #99169
+
+ -- Joey Hess <joeyh@debian.org> Wed, 30 May 2001 16:24:09 -0400
+
debhelper (3.0.27) unstable; urgency=low
* Fixed issues with extended parameters to dh_gencontrol including spaces
diff --git a/dh_clean b/dh_clean
index 341d1fbf..d86743a5 100755
--- a/dh_clean
+++ b/dh_clean
@@ -81,6 +81,15 @@ if (! $dh{D_FLAG}) {
doit("rm","-f","debian/files");
}
+ # Remove some files that were left around by older versions of
+ # debhelper, just in case someone upgrades in the middle of a
+ # build.
+ doit("rm","-f","debian/substvars",
+ "debian/postinst.debhelper",
+ "debian/postrm.debhelper",
+ "debian/preinst.debhelper",
+ "debian/prerm.debhelper");
+
# See if some files that would normally be deleted are excluded.
my $find_options='';
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {