summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-01-12 12:32:49 -0500
committerJoey Hess <joey@kodama.kitenet.net>2008-01-12 12:32:49 -0500
commit651159b311097089d241e2715dd18fa60da10aa3 (patch)
tree3f05aa4e7b0663c25a9e3fcd26959ec53a4e14f3
parent44097a184c49114de52bdaf464afe952c4273e01 (diff)
releasing version 6.0.2
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdocs3
-rwxr-xr-xdh_installexamples4
3 files changed, 10 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 9cb96ecd..fbcea8c7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (6.0.2) unstable; urgency=low
+
+ * Revert slightly broken refactoring of some exclude code.
+ Closes: #460340, #460351
+
+ -- Joey Hess <joeyh@debian.org> Sat, 12 Jan 2008 12:31:15 -0500
+
debhelper (6.0.1) unstable; urgency=low
* dh_installdocs/examples: Don't unnecessarily use the exclude code path.
diff --git a/dh_installdocs b/dh_installdocs
index 3707a136..35672369 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -137,8 +137,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $dir = ($basename eq '.') ? $doc : "$doc/..";
my $pwd=`pwd`;
chomp $pwd;
- $exclude='\\( -type f -or -type l \\)'.$exclude;
- complex_doit("cd '$dir' && find '$basename' $exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package \\;");
+ complex_doit("cd '$dir' && find '$basename' \\( -type f -or -type l \\)$exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package \\;");
}
else {
doit("cp", "-a", $doc, "$tmp/usr/share/doc/$package");
diff --git a/dh_installexamples b/dh_installexamples
index 1e10e65b..3e5e0893 100755
--- a/dh_installexamples
+++ b/dh_installexamples
@@ -90,8 +90,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $dir = ($basename eq '.') ? $example : "$example/..";
my $pwd=`pwd`;
chomp $pwd;
- $exclude = '-type f'.$exclude;
- complex_doit("cd '$dir' && find '$basename' $exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package/examples \\;");
+ my $exclude2 = '-type f'.$exclude;
+ complex_doit("cd '$dir' && find '$basename' -type f$exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package/examples \\;");
}
else {
doit("cp", "-a", $example, "$tmp/usr/share/doc/$package/examples");