summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-11-12 01:26:42 +0000
committerjoey <joey>2000-11-12 01:26:42 +0000
commit6965a7d27d2cf0024f8c791f155b7c01019e364e (patch)
tree100bb55a86c0c085fa2c149f11adcc319bb49402
parent8c74b979583bfd18eeb2e2262c751cdb42c85f00 (diff)
r386: * dh_makeshlibs: Also scan files named "*.so*", not just "*.so.*",
but only if they are files. This should make it more usable with rather stupidly broken libraries like db3, which do not encode the major version in their filenames. However, it cannot guess the major version of such libraries, so -m must be used.
-rw-r--r--debian/changelog10
-rwxr-xr-xdh_makeshlibs4
2 files changed, 12 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8113923e..0291a0a0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (2.1.23) unstable; urgency=low
+
+ * dh_makeshlibs: Also scan files named "*.so*", not just "*.so.*",
+ but only if they are files. This should make it more usable with
+ rather stupidly broken libraries like db3, which do not encode the
+ major version in their filenames. However, it cannot guess the major
+ version of such libraries, so -m must be used.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 11 Nov 2000 17:24:58 -0800
+
debhelper (2.1.22) unstable; urgency=low
* Fixed dh_perl to work with perl 5.6, Closes: #76508
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 66781c7e..1e48146c 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -12,7 +12,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
doit("rm", "-f", "$TMP/DEBIAN/shlibs");
- open (FIND, "find $TMP -xtype f -name '*.so.*' |");
+ open (FIND, "find $TMP -xtype f -name '*.so*' |");
while (<FIND>) {
chomp;
($library, $major)=m#.*/(.*)\.so\.(\d*)\.?#;
@@ -34,7 +34,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$deps="$PACKAGE (>= $dh{VERSION})";
}
}
- if (defined($library) && defined($major) && defined($deps) &&
+ if (defined($library) && defined($major) && defined($deps) &&
$library ne '' && $major ne '' && $deps ne '') {
# Prevent duplicate lines from entering the file.
my $line="$library $major $deps";