summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-06-11 22:27:35 +0000
committerjoey <joey>2001-06-11 22:27:35 +0000
commit6c796faa1c65d40456d1137ea84fe92dbf258fc7 (patch)
tree33077417bb6c9097eb3e7bd3dea1faa544042ad8
parente8b9fc5324e8c645d0c18d165e4b7f7bc94c8242 (diff)
r478: * dh_gencontrol: Work around very strange hurd semantics
which allow "" to be an empty file. Closes: #100542
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_gencontrol2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4ca7abea..83822020 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.33) unstable; urgency=low
+
+ * dh_gencontrol: Work around very strange hurd semantics
+ which allow "" to be an empty file. Closes: #100542
+
+ -- Joey Hess <joeyh@debian.org> Mon, 11 Jun 2001 18:15:19 -0400
+
debhelper (3.0.32) unstable; urgency=low
* Check that update-modules is present before running it, since modutils
diff --git a/dh_gencontrol b/dh_gencontrol
index d305b961..99923cf4 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -63,7 +63,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Merge in user-specified substvars file with debhelper generated
# one.
my $substvars=pkgfile($package,"substvars");
- if (-e $substvars) {
+ if ($substvars) {
complex_doit("cat $substvars >> debian/${ext}substvars.debhelper");
}