summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-14 14:15:24 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-14 14:15:24 -0400
commit6edaecf8073d72cb1319c1fb60ce90a021d18616 (patch)
tree86d15e02f09b8e3f844aac2242e95858888a28de
parentf2d18ce6c66b6d45b90b13cbd07b61977fbd123c (diff)
dh_auto_configure: Revert --skipdeps change Closes: #528647, reopens: #528235
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_auto_configure4
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5809a4eb..916e72f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.12) UNRELEASED; urgency=low
+
+ * dh_auto_configure: Revert --skipdeps change
+ Closes: #528647, reopens: #528235
+
+ -- Joey Hess <joeyh@debian.org> Thu, 14 May 2009 13:44:18 -0400
+
debhelper (7.2.11) unstable; urgency=low
* dh: Support --with addon,addon,...
diff --git a/dh_auto_configure b/dh_auto_configure
index a320df95..d69ed162 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -89,10 +89,10 @@ if (-x "configure") {
}
elsif (-e "Makefile.PL") {
# If set to a true value then MakeMaker's prompt function will
- # # always return the default without waiting for user input.
+ # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
- "create_packlist=0", "--skipdeps", @{$dh{U_PARAMS}});
+ "create_packlist=0", @{$dh{U_PARAMS}});
}
elsif (-e "Build.PL") {
$ENV{PERL_MM_USE_DEFAULT}=1; # Module::Build can also use this.