summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-08-24 20:22:13 +0000
committerjoey <joey>2005-08-24 20:22:13 +0000
commit7c8bae9e6b2dad06a0e7c9b4317987049eb65537 (patch)
treea57c455ee5f5ca270c86cb5840eba40406a9b094
parentee7ee03588981e45e8b664afc02b4ad19f0027bd (diff)
r1779: releasing version 4.9.6
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdocs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bb394f4c..28d5e796 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.9.6) unstable; urgency=low
+
+ * dh_installdocs: Install symlinks to in -x mode, same as in non exclude
+ mode. Closes: #324161
+
+ -- Joey Hess <joeyh@debian.org> Wed, 24 Aug 2005 16:20:02 -0400
+
debhelper (4.9.5) unstable; urgency=low
* dh_install: in v5 mode, error out if there are wildcards in the file
diff --git a/dh_installdocs b/dh_installdocs
index 52d1675f..9c12d49d 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -133,7 +133,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Pity there's no cp --exclude ..
my $pwd=`pwd`;
chomp $pwd;
- complex_doit("cd $doc/.. && find $dir_basename -type f$exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package \\;");
+ complex_doit("cd $doc/.. && find $dir_basename \\( -type f or -type l \\)$exclude -exec cp --parents -dp {} $pwd/$tmp/usr/share/doc/$package \\;");
}
else {
doit("cp","-a",$doc,"$tmp/usr/share/doc/$package");