summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-24 14:25:35 -0400
committerJoey Hess <joey@kitenet.net>2011-06-24 14:25:35 -0400
commit878f25308d548106ba126715e68776e42ee8b626 (patch)
tree5564a2dd7c1a50dd20eaa70413ccd63214533ca9
parentf24df6415586bd07fb5903fba3252495c4e5c065 (diff)
dh_auto_configure: If there is a problem with cmake, display the CMakeCache.txt.
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm10
-rw-r--r--debian/changelog2
2 files changed, 11 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index d4a98f43..9e40cb72 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -44,7 +44,15 @@ sub configure {
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
$this->mkdir_builddir();
- $this->doit_in_builddir("cmake", $this->get_source_rel2builddir(), @flags, @_);
+ eval {
+ $this->doit_in_builddir("cmake", $this->get_source_rel2builddir(), @flags, @_);
+ };
+ if ($@) {
+ if (-e $this->get_buildpath("CMakeCache.txt")) {
+ $this->doit_in_builddir("tail -v -n +0 CMakeCache.txt");
+ }
+ die $@;
+ }
}
sub test {
diff --git a/debian/changelog b/debian/changelog
index 57eb40c7..ff81dc30 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,8 @@ debhelper (8.1.7) UNRELEASED; urgency=low
* Correct docs about multiarch and v9. Closes: #630826
* Fix example. Closes: #627534
* Fix error message. Closes: #628053
+ * dh_auto_configure: If there is a problem with cmake, display
+ the CMakeCache.txt.
-- Joey Hess <joeyh@debian.org> Sat, 21 May 2011 15:24:19 -0400