summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-07 16:33:46 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-07 16:33:46 -0400
commit94f05f40141f7005a711850eee8f5f7566c3a647 (patch)
tree3243c0b107e742345c0ef94c9478c29f1bac7487
parentfa78ca81c39a4c255e23e601eb2752a7be2e9ba3 (diff)
Close COMPAT_IN filehandle. Closes: #527464
-rw-r--r--Debian/Debhelper/Dh_Lib.pm1
-rw-r--r--debian/changelog6
2 files changed, 7 insertions, 0 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index b57c4d97..829eabfc 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -300,6 +300,7 @@ sub dirname {
# Try the file..
open (COMPAT_IN, "debian/compat") || error "debian/compat: $!";
my $l=<COMPAT_IN>;
+ close COMPAT_IN;
if (! defined $l || ! length $l) {
warning("debian/compat is empty, assuming level $c");
}
diff --git a/debian/changelog b/debian/changelog
index 0b204eb8..3b9e42ae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.2.10) UNRELEASED; urgency=low
+
+ * Close COMPAT_IN filehandle. Closes: #527464
+
+ -- Joey Hess <joeyh@debian.org> Thu, 07 May 2009 16:33:25 -0400
+
debhelper (7.2.9) unstable; urgency=low
* dh_fixperms: Ensure lintian overrides are mode 644.