summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-09-01 13:20:37 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-09-01 13:20:37 -0400
commita432550b565cd01d4a67b8cb929f90fa29d299f7 (patch)
tree3a27c356fe53a63adf506b20f8ad6cceac41e2a7
parent8fc9ed5241e752d51da71982116730e9c7287cb9 (diff)
Optimise -s handling to avoid running dpkg-architecture if the package is arch all.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm4
-rw-r--r--debian/changelog7
2 files changed, 10 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index cd87ebe5..4ccd12ae 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -714,11 +714,13 @@ sub getpackages {
$package_types{$package}=$package_type;
$package_arches{$package}=$arch;
}
+
if ($package &&
(($type eq 'indep' && $arch eq 'all') ||
($type eq 'arch' && $arch ne 'all') ||
($type eq 'same' && ($arch eq 'any' ||
- samearch(buildarch(), $arch))) ||
+ ($arch ne 'all' &&
+ samearch(buildarch(), $arch)))) ||
! $type)) {
push @list, $package;
$package="";
diff --git a/debian/changelog b/debian/changelog
index 5b495fa8..c0fdd8bd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.3.17) UNRELEASED; urgency=low
+
+ * Optimise -s handling to avoid running dpkg-architecture if the package
+ is arch all.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 01 Sep 2009 13:19:55 -0400
+
debhelper (7.3.16) unstable; urgency=low
* dh_desktop: Clarify in man page why it's a no-op.