summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-15 02:35:09 +0000
committerjoey <joey>2001-05-15 02:35:09 +0000
commitabb4a093bd111a1f01d73eb2e84c015830d04f1f (patch)
tree9a1aed229c971000497f58e78af3856ad380e844
parentd7b306162c16a3d261fe6c7420ac484ac3d9f3ea (diff)
r468: * dh_shlibdeps: the -l switch now just adds to LD_LIBRARY_PATH, if it is
already set. Newer fakeroots set it, and clobbering their settings breaks things since they LD_PRELOAD a library that is specified in the LD_LIBRARY_PATH. (blah) Closes: #97494
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_shlibdeps5
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0158f610..2d6115fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (3.0.23) unstable; urgency=low
+
+ * dh_shlibdeps: the -l switch now just adds to LD_LIBRARY_PATH, if it is
+ already set. Newer fakeroots set it, and clobbering their settings
+ breaks things since they LD_PRELOAD a library that is specified in the
+ LD_LIBRARY_PATH. (blah) Closes: #97494
+
+ -- Joey Hess <joeyh@debian.org> Mon, 14 May 2001 22:32:23 -0400
+
debhelper (3.0.22) unstable; urgency=low
* dh_installinfo: doc enchancement, Closes: #97515
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 552687e4..ebba4746 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -42,7 +42,7 @@ may be used more than once to exclude more than one thing.
=item B<-l>I<directory>[:directory:directory:..]
-Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will be set to the
+Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will have added to it the
specified directory (or directories -- separate with colons). This is
useful for multi-binary packages where a library is built in one
package and another package contains binaries linked against said
@@ -79,6 +79,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (@filelist) {
if ($dh{L_PARAMS}) {
my @paths=();
+ # Add to existing paths, if set.
+ push @paths, $ENV{'LD_LIBRARY_PATH'}
+ if exists $ENV{'LD_LIBRARY_PATH'}
foreach (split(/:/, $dh{L_PARAMS})) {
# Force the path absolute.
if (m:^/:) {