summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-01-04 15:41:14 -0500
committerJoey Hess <joey@kodama.kitenet.net>2008-01-04 15:41:14 -0500
commitad83d2b881df3acd02925da328359b47c7b0f874 (patch)
tree859f68296f4d96adb1d4c61e6483120ccd242686
parent73a6f7412a85594660bcd0e8c83efdec794468fa (diff)
* dh_shlibdeps: Update documentation for -L and -l. dpkg-shlibdeps is now
much smarter, and these options are almost never needed. Closes: #459226 * dh_shlibdeps: If a relative path is specified in -l, don't prepend the pwd to it, instead just prepend a slash to make it absolute. dpkg-shlibdeps has changed how it used LD_LIBRARY_PATH, so making it point into the package build directory won't work.
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_shlibdeps30
2 files changed, 21 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f623c73..6fd992dc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,12 @@
debhelper (5.0.64) UNRELEASED; urgency=low
* dh_gencontrol: Stop passing -isp, it's the default now. Closes: #458114
+ * dh_shlibdeps: Update documentation for -L and -l. dpkg-shlibdeps is now
+ much smarter, and these options are almost never needed. Closes: #459226
+ * dh_shlibdeps: If a relative path is specified in -l, don't prepend the pwd
+ to it, instead just prepend a slash to make it absolute. dpkg-shlibdeps
+ has changed how it used LD_LIBRARY_PATH, so making it point into the
+ package build directory won't work.
-- Joey Hess <joeyh@debian.org> Fri, 28 Dec 2007 15:45:39 -0500
diff --git a/dh_shlibdeps b/dh_shlibdeps
index dad0165c..cfbfa2de 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -42,23 +42,23 @@ may be used more than once to exclude more than one thing.
=item B<-l>I<directory>[:directory:directory:..]
-Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will have added to it the
-specified directory (or directories -- separate with colons). This is
-useful for multi-binary packages where a library is built in one
-package and another package contains binaries linked against said
-library. Relative paths will be made absolute for the benefit of
-dpkg-shlibdeps.
+With recent versions of dpkg-shlibdeps, this option is generally not
+needed.
-Note that the directory given should be the complete or relative path to
-a directory that contains the library. See example below.
+Before dpkg-shlibdeps is run, LD_LIBRARY_PATH will have added to it the
+specified directory (or directories -- separate with colons). With recent
+versions of dpkg-shlibdeps, this is mostly only useful for packages that
+build multiple flavors of the same library, or other situations where
+the library is installed into a directory not on the regular library search
+path.
=item B<-L>I<package>, B<--libpackage=>I<package>
-Use the shlibs file automatically generated by dh_makeshlibs for the named
-package as a kind of automatically generated shlibs.local file. You can use
-this switch in concert with the -l switch to make dpkg-shlibdeps find a
-library built as part of the current package, and get the shlibs information.
-See example below.
+With recent versions of dpkg-shlibdeps, this option is generally not
+needed.
+
+Tell dpkg-shlibdeps to use the shlibs file automatically generated by
+dh_makeshlibs for the named package instead of the shlibs.local file.
=back
@@ -69,7 +69,7 @@ libfoo-bin binary packages. libfoo-bin links against libfoo1, and should
depend on it. In your rules file, first run dh_makeshlibs, then dh_shlibdeps:
dh_makeshlibs
- dh_shlibdeps -L libfoo1 -l debian/libfoo1/usr/lib
+ dh_shlibdeps
This will have the effect of generating automatically a shlibs file for
libfoo1, and using that file and the libfoo1 library in the
@@ -91,7 +91,7 @@ if ($dh{L_PARAMS}) {
push @paths, $_;
}
else {
- push @paths, getcwd()."/$_";
+ push @paths, "/$_";
}
}
$dh{L_PARAMS}=join(':', @paths);