summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-12-03 23:57:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-12-04 15:00:16 -0500
commitce069424bc9a14aaefc06871d0ea530c0e26bbb7 (patch)
treeef0535423e1b8f32bbb2f66b33f4de22cd945599
parent3358de78fe59904aab34abdb4948ec8e9b19d171 (diff)
Remove legacy punctuation hacks tests which no longer work by design.
I assume backwards compatibility in this area was broken by design. Adding --max-parallel to these in 6dd27753803ae2091a9fc3aedc8e70548ea87675 was wrong and negated their whole point, i.e. testing of backwards compatibility when parallel options were not supported. (cherry picked from commit ca0ad4922ada7ae013b035cfe1550a257a330809)
-rwxr-xr-xt/buildsystems/buildsystem_tests44
1 files changed, 4 insertions, 40 deletions
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index 34b18773..2204f3f5 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -1,6 +1,6 @@
#!/usr/bin/perl
-use Test::More tests => 297;
+use Test::More tests => 291;
use strict;
use warnings;
@@ -606,53 +606,17 @@ sub do_rules_for_parallel {
doit("ln", "-s", "parallel.mk", "Makefile");
-# Test if legacy punctuation hacks (+) work as before
+# Test if dh+override+$(MAKE) legacy punctuation hack work as before
$ENV{MAKEFLAGS} = "-j5";
$ENV{DEB_BUILD_OPTIONS} = "parallel=5";
-$tmp = write_debian_rules(<<'EOF');
-#!/usr/bin/make -f
-%:
- @dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
- @dh_clean > /dev/null 2>&1
-EOF
-test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
- "legacy punctuation hacks: +dh, no override" );
-unlink "debian/rules";
-write_debian_rules(<<'EOF');
-#!/usr/bin/make -f
-override_dh_auto_build:
- dh_auto_build
-%:
- @dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
- @dh_clean > /dev/null 2>&1
-EOF
-test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
- "legacy punctuation hacks: +dh, override without +, parallel, no make warnings" );
-unlink "debian/rules";
-
-write_debian_rules(<<'EOF');
-#!/usr/bin/make -f
-override_dh_auto_build:
- +dh_auto_build
-%:
- @dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
- @dh_clean > /dev/null 2>&1
-EOF
-test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
- "legacy punctuation hacks: +dh, override with +" );
-unlink "debian/rules";
-
-write_debian_rules(<<'EOF');
+$tmp = write_debian_rules(<<'EOF');
#!/usr/bin/make -f
override_dh_auto_build:
$(MAKE)
%:
@dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
+ @+dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),