summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-07-22 21:06:18 +0000
committerjoey <joey>2003-07-22 21:06:18 +0000
commitd579dae0cf159c50dcd902ff4a35590f7dcff395 (patch)
tree668991ca36223aa09d809da22edf252026b05d01
parent34ed74aef9d9c42de391dea7387884359d439f57 (diff)
r598: * dh_strip: do not strip files multiple times.
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_strip1
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 212e5052..4c03e6d8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.1.55) unstable; urgency=low
+
+ * dh_strip: do not strip files multiple times.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 22 Jul 2003 17:04:49 -0400
+
debhelper (4.1.54) unstable; urgency=low
* dh_scrollkeeper: fix postrm to not run if scrollkeeper is not present
diff --git a/dh_strip b/dh_strip
index 14f098ed..9e107f46 100755
--- a/dh_strip
+++ b/dh_strip
@@ -121,6 +121,7 @@ sub testfile {
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
+ @shared_libs=@executables=@static_libs=();
find(\&testfile,$tmp);
foreach (@shared_libs) {