summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-08-21 02:04:06 +0000
committerjoey <joey>2000-08-21 02:04:06 +0000
commite3534180b30e6f5e546078105bedfd5341664118 (patch)
tree60a635600b9df4b5854e3745f0d3e73c9fb98f51
parenta4664178e1e455907c0ae2c9caf089ee6b8d0cc2 (diff)
r367: * debian/package.filename.arch is now checked for first, before
debian/package.filename. Closes: #69453 * Added a section to debhelper(1) about files in debian/ used by debhelper, which documents this. Removed scattered references to debian/filename from all over the man pages.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm43
-rw-r--r--debhelper.129
-rw-r--r--debian/changelog10
-rw-r--r--dh_compress.128
-rw-r--r--dh_fixperms.16
-rw-r--r--dh_gencontrol.14
-rw-r--r--dh_installcron.17
-rw-r--r--dh_installdeb.129
-rw-r--r--dh_installdebconf.111
-rw-r--r--dh_installdirs.17
-rw-r--r--dh_installdocs.126
-rw-r--r--dh_installemacsen.19
-rw-r--r--dh_installexamples.110
-rw-r--r--dh_installinfo.19
-rw-r--r--dh_installinit.114
-rw-r--r--dh_installlogrotate.15
-rw-r--r--dh_installmanpages.12
-rw-r--r--dh_installmenu.19
-rw-r--r--dh_installmime.19
-rw-r--r--dh_installmodules.15
-rw-r--r--dh_installpam.15
-rw-r--r--dh_installwm.19
-rw-r--r--dh_installxaw.17
-rw-r--r--dh_link.114
-rw-r--r--dh_md5sums.12
-rw-r--r--dh_movefiles.12
-rw-r--r--dh_perl.16
-rw-r--r--dh_shlibdeps.14
-rw-r--r--dh_suidregister.111
-rw-r--r--dh_undocumented.113
-rw-r--r--doc/TODO8
31 files changed, 173 insertions, 180 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 92059daa..053dacd1 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -222,19 +222,28 @@ sub tmpdir { my $package=shift;
}
# Pass this the name of a binary package, and the name of the file wanted
-# for the package, and it will return the actual filename to use. For
-# example if the package is foo, and the file is somefile, it will look for
-# debian/somefile, and if found return that, otherwise, if the package is
-# the main package, it will look for debian/foo, and if found, return that.
-# Failing that, it will return nothing.
-sub pkgfile { my $package=shift; my $filename=shift;
- if (-f "debian/$package.$filename") {
+# for the package, and it will return the actual existing filename to use.
+#
+# It tries several filenames:
+# * debian/package.filename.buildarch
+# * debian/package.filename
+# * debian/file (if the package is the main package)
+sub pkgfile {
+ my $package=shift;
+ my $filename=shift;
+
+ if (-f "debian/$package.$filename.".buildarch()) {
+ return "debian/$package.$filename".buildarch();
+ }
+ elsif (-f "debian/$package.$filename") {
return "debian/$package.$filename";
}
elsif ($package eq $dh{MAINPACKAGE} && -f "debian/$filename") {
return "debian/$filename";
}
- return "";
+ else {
+ return "";
+ }
}
# Pass it a name of a binary package, it returns the name to prefix to files
@@ -328,6 +337,19 @@ sub filearray { my $file=shift;
return @ret;
}
+# Returns the build architecture. (Memoized)
+{
+ my $arch;
+
+ sub buildarch {
+ return $arch if defined $arch;
+
+ $arch=`dpkg --print-architecture` || error($!);
+ chomp $arch;
+ return $arch;
+ }
+}
+
# Returns a list of packages in the control file.
# Must pass "arch" or "indep" or "same" to specify arch-dependant or
# -independant or same arch packages. If nothing is specified, returns all
@@ -336,10 +358,9 @@ sub GetPackages { my $type=shift;
$type="" if ! defined $type;
# Look up the build arch if we need to.
- my$buildarch='';
+ my $buildarch='';
if ($type eq 'same') {
- $buildarch=`dpkg --print-architecture` || error($!);
- chomp $buildarch;
+ $buildarch=buildarch();
}
my $package="";
diff --git a/debhelper.1 b/debhelper.1
index 4fc21c67..d52c82a4 100644
--- a/debhelper.1
+++ b/debhelper.1
@@ -7,7 +7,7 @@ debhelper \- overview of the debhelper commands
.SH "DESCRIPTION"
Debhelper is used to help you build a debian package. The philospohy behind
debhelper is to provide a collection of small, simple, and easily
-understood tools that are used in debian/rules to automate various common
+understood tools that are used in debian/rules to automate various common
aspects of building a package. This means less work for you, the packager.
It also, to some degree means that these tools can be changed if debian
policy changes, and packages that use them will require only a rebuild to
@@ -20,7 +20,7 @@ Examples of rules files that use debhelper are in
.P
To create a new debian package using debhelper, you can just copy one of
the sample rules files and edit it by hand. Or you can try the dh-make
-package, which contains a
+package, which contains a
.BR dh_make (1)
command that partially automates the process. For a more gentle
introduction, the maint-guide debian package contains a
@@ -29,6 +29,27 @@ tutorial about making your first package using debhelper.
Here is the complete list of available debhelper commands. See their man
pages for additional documentation.
#LIST#
+.SH "DEBHELPER CONFIG FILES"
+Many debhelper commands make use of files in debian/ to control what they
+do. Besides the common debian/changelog and debian/control, which are
+in all packages, not just those using debhelper, some additional files can
+be used to configure the behavior of specific debhelper commands. These
+files are typically named debian/<package>.foo (where <package> of course,
+is replaced with the package that is being acted on).
+.P
+For example,
+dh_installdocs uses files named debian/<package>.docs to list the documentation
+files it will install. See the man pages of individual commands for details
+about the names and formats of the files they use.
+.P
+Note that if a package is the first (or only) binary package listed in
+debian/control, debhelper will use debian/foo if no debian/<package>.foo
+file can be found.
+.P
+In some rare cases, you may want to have different versions of these files
+for different architectures. If files named debian/<package>.foo.<arch>
+exist, where <arch> is the same as the output of "dpkg --print-architecture",
+then they will be used in preference to other, more general files.
.SH "SHARED DEBHLPER OPTIONS"
The following command line options are supported by all debhelper programs.
.TP
@@ -91,7 +112,7 @@ binary-arch debian/rules target, and the architecture independent packages
in the binary-indep debian/rules target.
To facilitate this, as well as give you more control over which packages
-are acted on by debhelper programs, all debhelper programs accept the
+are acted on by debhelper programs, all debhelper programs accept the
.B -a
,
.B -i
@@ -187,7 +208,7 @@ Note that if you are generating a debian package that has arch-indep and
arch-dependent portions, and you are using dh_movefiles to move the
arch-indep files out of debian/tmp, you need to make sure that dh_movefiles
does this even if only the arch-dependent package is being built (for
-ports to other architectures). I handle this in the example rules file
+ports to other architectures). I handle this in the example rules file
"rules.multi" by calling dh_movefiles in the install target.
.P
Once your package uses debhelper to build, be sure to add
diff --git a/debian/changelog b/debian/changelog
index c5bc10d2..e4c17344 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (2.1.7) unstable; urgency=low
+
+ * debian/package.filename.arch is now checked for first, before
+ debian/package.filename. Closes: #69453
+ * Added a section to debhelper(1) about files in debian/ used by
+ debhelper, which documents this. Removed scattered references to
+ debian/filename from all over the man pages.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2000 18:06:52 -0700
+
debhelper (2.1.6) unstable; urgency=low
* dh_strip: now knows about the DEB_BUILD_OPTIONS=nostrip thing.
diff --git a/dh_compress.1 b/dh_compress.1
index 849af0d1..e3319df6 100644
--- a/dh_compress.1
+++ b/dh_compress.1
@@ -11,31 +11,18 @@ that pointed to the files before they were compressed are updated to point
to the new files.
.P
By default, dh_compress compresses files that debian policy mandates should
-be compressed, namely all files in usr/share/info, usr/share/man,
+be compressed, namely all files in usr/share/info, usr/share/man,
usr/X11R6/man, and all files in usr/share/doc that are larger than 4k in size,
-(except the copyright file, .html files and .gif files), and all changelog
+(except the copyright file, .html files and .gif files), and all changelog
files. It skips any files that appear to be already compressed (based on their
extensions).
.P
-If a debian/package.compress file exists (debian/compress may be used for the
-first binary package in debian/control), however, it will be ran as a shell
+If a debian/package.compress file exists, however, it will be ran as a shell
script, and all filenames that the shell script outputs will be compressed
instead of the default files. Note that the shell script will be run from
inside the package build directory. Note though that using -X is a much
-better idea in general; you should only use a debian/compress file if you
-really have to.
-.SH EXAMPLE
-Here is a sample debian/compress file that causes dh_compress to compress
-the same files as it would by default. This is a good starting point for
-customization of what files are compressed:
-.PP
- find usr/info usr/share/info usr/man usr/share/man usr/X11*/man -type f ! -name "*.gz"
- find usr/doc usr/share/doc -type f \\
- \\( -size +4k -or -name "changelog*" \\) \\
- \\( -name changelog.html -or ! -iname "*.htm*" \\) \\
- ! -iname "*.gif" ! -iname "*.png" ! -iname "*.jpg" ! -iname "*.jpeg" ! -iname "*.gz" \\
- ! -iname "*.taz" ! -iname "*.tgz" ! -iname "*.z" \\
- ! -name "copyright"
+better idea in general; you should only use a debian/package.compress file if
+you really have to.
.SH OPTIONS
.TP
.B debhelper options
@@ -56,11 +43,6 @@ acted on.
.TP
.B file ...
Add these files to the list of files to compress.
-.SH NOTES
-The debian/compress file applies to the first binary package listed in your
-control file. For the other packages, you can make files named
-debian/package.compress, where "package" is the name of the package they
-apply to. (This works for the first binary package too.)
.SH ENVIRONMENT
See
.BR debhelper (1)
diff --git a/dh_fixperms.1 b/dh_fixperms.1
index c69a1437..debc8ec3 100644
--- a/dh_fixperms.1
+++ b/dh_fixperms.1
@@ -10,8 +10,8 @@ permissions of files and directories in package build directories to a
sane state -- a state that complies with Debian policy.
.P
dh_fixperms makes all files in usr/share/doc in the package build directory
-(excluding files in the examples/ directory) be mode 644. It also changes
-the permissions of all man pages to mode 644. It makes all files be owned by
+(excluding files in the examples/ directory) be mode 644. It also changes
+the permissions of all man pages to mode 644. It makes all files be owned by
root, and it removes group and other write permission from all files.
It removes execute permissions from any libraries that have it set. Finally,
it removes the setuid and setgid bits from all files in the package.
@@ -24,7 +24,7 @@ for a list of options common to all debhelper commands.
.TP
.B \-Xitem, \--exclude=item
Exclude files that contain "item" anywhere in their filename from having
-their permissions changed. You may use this option multiple times to build
+their permissions changed. You may use this option multiple times to build
up a list of things to exclude.
.SH ENVIRONMENT
See
diff --git a/dh_gencontrol.1 b/dh_gencontrol.1
index 03855c51..421acd22 100644
--- a/dh_gencontrol.1
+++ b/dh_gencontrol.1
@@ -5,7 +5,7 @@ dh_gencontrol \- generate and install control file
.B dh_gencontrol
.I "[debhelper options] [-uparams] [-- params]"
.SH "DESCRIPTION"
-dh_gencontrol is a debhelper program that is responsible for generating
+dh_gencontrol is a debhelper program that is responsible for generating
control files, and installing them into the DEBIAN directory with the proper
permissions.
.P
@@ -21,7 +21,7 @@ for a list of options common to all debhelper commands.
.B \-uparams, \--dpkg-gencontrol-params=params
.TP
.B \-\- params
-Pass "params" to
+Pass "params" to
.BR dpkg-gencontrol (1)
.SH ENVIRONMENT
See
diff --git a/dh_installcron.1 b/dh_installcron.1
index 146d5cf7..2dd53dee 100644
--- a/dh_installcron.1
+++ b/dh_installcron.1
@@ -7,11 +7,8 @@ dh_installcron \- install cron scripts into etc/cron.*
.SH "DESCRIPTION"
dh_installcron is a debhelper program that is responsible for installing
cron scripts into etc/cron.* in package build directories. The files
-debian/cron.daily, debian/cron.weekly, debian/cron.monthly, and debian/cron.d
-are installed. If your package generates multiple binary packages (or if you
-just prefer to do it), you can also use filenames like
-debian/package.cron.daily, where "package" is replaced with the name of the
-binary package this cron script goes into.
+debian/package.cron.daily, debian/package.cron.weekly,
+debian/package.cron.monthly, and debian/package.cron.d are installed.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installdeb.1 b/dh_installdeb.1
index 9a8dd79b..df305978 100644
--- a/dh_installdeb.1
+++ b/dh_installdeb.1
@@ -11,25 +11,20 @@ correct permissions.
.P
dh_installdeb automatically installs the following files from debian/ into
the DEBIAN directory:
- postinst
- preinst
- postrm
- prerm
- shlibs
- conffiles
+ package.postinst
+ package.preinst
+ package.postrm
+ package.prerm
+ package.shlibs
+ package.conffiles
.P
-(For packages other than the first binary package listed in debian/control,
-you must prefix these filenames with then name of the "package.", for example,
-"foo.postinst". You can also prefix the filenames the same way for the first
-binary package, for consitency.)
-.P
-The files postinst, preinst, postrm, and prerm are handled specially: If a
-corresponding file named debian/script.debhelper exists, the contents of that
-file are merged into the script as follows: If the script exists, then
+The postinst, preinst, postrm, and prerm are handled specially: If a
+corresponding file named debian/script.debhelper exists, the contents of that
+file are merged into the script as follows: If the script exists, then
anywhere in it that "#DEBHELPER#" appears, the text of the .debhelper file is
-inserted. If the script does not exist, then a script is generated from
-the .debhelper file. The .debhelper files are created by other debhelper
-programs, such as
+inserted. If the script does not exist, then a script is generated from
+the .debhelper file. The .debhelper files are created by other debhelper
+programs, such as
.BR dh_installmenu (1)
, and are shell script fragments.
.SH OPTIONS
diff --git a/dh_installdebconf.1 b/dh_installdebconf.1
index b423679c..18ccf57b 100644
--- a/dh_installdebconf.1
+++ b/dh_installdebconf.1
@@ -8,17 +8,14 @@ dh_installdebconf \- install debconf files into package build directories
dh_installdebconf is a debhelper program that is responsible for installing
files used by the debconf package into package build directories.
.P
-It also automatically generates the postrm commands needed to
-interface with debconf. See
+It also automatically generates the postrm commands needed to
+interface with debconf. See
.BR dh_installdeb (1)
for an explanation of how this works.
.P
Files named debian/package.config and debian/package.templates are installed
into the DEBIAN directory in the package build directory.
.P
-For the first first binary package listed in the control file, you may use
-debian/config and debian/templates instead.
-.P
Note that if you use debconf, your package probably needs to depend on it.
.SH "LOCALIZED TEMPLATE FILES"
Debconf also supports localized template files, and this program has some
@@ -27,14 +24,14 @@ translations in separate files, and merge them only at build time. See
.BR debconf-mergetemplate (1)
for details.
.P
-This program will automatically call
+This program will automatically call
.BR debconf-mergetemplate (1)
and merge templates on the fly if it finds your template files are accompnied
by translated files that have the same name as the template file, with a
dot and two letters prepended.
.P
For example, if you have a German translation,
-debian/templates.de is merged with debian/templates.
+debian/package.templates.de is merged with debian/package.templates.
.P
If you use this feature, your package should build-depend on debconf-utils.
.SH OPTIONS
diff --git a/dh_installdirs.1 b/dh_installdirs.1
index 29e39059..c2ce94cf 100644
--- a/dh_installdirs.1
+++ b/dh_installdirs.1
@@ -10,11 +10,10 @@ subdirectories in package build directories.
.P
Any directory names specified as parameters will be created in the package
build directory of the first package dh_installdirs is told to act on. By
-default, this is the first binary package in debian/control, but if you use
+default, this is the first binary package in debian/control, but if you use
-p, -i, or -a flags, it will be the first package specified by those flags.
.P
-A file named debian/package.dirs (debian/dirs may be used for the first
-binary package in debian/control) can list other directories to be created.
+A file named debian/package.dirs can list other directories to be created.
Separate the directory names with whitespace.
.P
Be sure to only use directory names relative to the package build
@@ -41,6 +40,6 @@ for a list of environment variables that affect all debhelper commands.
.BR debhelper (1)
.SH BUGS
It's impossible to specify filenames with spaces or other whitespace in them
-in debian/dirs file. This is more a historical design flaw than a bug.
+in debian/package.dirs file. This is more a historical design flaw than a bug.
.SH AUTHOR
Joey Hess <joeyh@debian.org>
diff --git a/dh_installdocs.1 b/dh_installdocs.1
index c3ab4b42..7cc0623f 100644
--- a/dh_installdocs.1
+++ b/dh_installdocs.1
@@ -11,24 +11,23 @@ documentation into usr/share/doc/package in package build directories.
dh_installdocs automatically installs debian/copyright if it exists. If
dh_installdocs is acting on multiple packages, debian/copyright files will be
installed into all packages. However, if you need to have seperate copyright
-files for different binary packages, you can use files named
+files for different binary packages, you can use files named
debian/package.copyright.
.P
Any filenames specified as parameters will be installed into the first
-package dh_installdocs is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
+package dh_installdocs is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags, it
will be the first package specified by those flags.
.P
-Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
-they exist, will be installed into the first binary package listed in
-debian/control, if dh_installdocs is acting on that package. Note that
-debian/TODO will be installed named TODO.Debian, if the package is not a
+Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
+they exist, will be installed into the first binary package listed in
+debian/control, if dh_installdocs is acting on that package. Note that
+debian/TODO will be installed named TODO.Debian, if the package is not a
debian native package. Also note that README.debian is installed as
README.Debian, for consitency. Note that debian/package.README.Debian and
debian/package.TODO can be used to specify files for subpackages.
.P
-A file named debian/package.docs (debian/docs may be used for the first
-binary package in debian/control) can list other files to be installed.
+Files named debian/package.docs can list other files to be installed.
.P
This program will automatically generate postinst and prerm commands to
maintain a compatability symlink, /usr/doc/package, to the documentation in
@@ -36,10 +35,9 @@ maintain a compatability symlink, /usr/doc/package, to the documentation in
.BR dh_installdeb (1)
for an explanation of how this works.
.P
-A file named debian/package.doc-base (debian/doc-base may be used for the
-first binary package in debian/control), if it exists, will be installed as
-a doc-base control file, and will make this program automatically generate the
-postinst and prerm commands needed to interface with the doc-base package. See
+Files named debian/package.doc-base, will be installed as doc-base control
+files, and will make this program automatically generate the postinst and
+prerm commands needed to interface with the doc-base package. See
.BR dh_installdeb (1)
for an explanation of how this works.
Note that the doc-id will be determined from the "Document:" entry in the
@@ -83,7 +81,7 @@ between invocations of this command. Otherwise, it may cause multiple
instances of the same text to be added to maintainer scripts.
.SH BUGS
It's impossible to specify filenames with spaces or other whitespace in them
-in debian/docs file. This is more a historical design flaw than a bug.
+in debian/package.docs file. This is more a historical design flaw than a bug.
.SH "CONFORMS TO"
Debian policy, version 3.0.1
.SH AUTHOR
diff --git a/dh_installemacsen.1 b/dh_installemacsen.1
index 7615ad6c..963e2268 100644
--- a/dh_installemacsen.1
+++ b/dh_installemacsen.1
@@ -6,10 +6,10 @@ dh_installemacsen \- register an emacs add on package
.I "[debhelper options] [-n] [--priority=n] [--flavor=foo]"
.SH "DESCRIPTION"
dh_installemacsen is a debhelper program that is responsible for installing
-files used by the debian emacsen-common package into package build directories.
+files used by the debian emacsen-common package into package build directories.
.P
-It also automatically generates the postinst and prerm commands needed to
-register a package as an emacs add on package. See
+It also automatically generates the postinst and prerm commands needed to
+register a package as an emacs add on package. See
.BR dh_installdeb (1)
for an explanation of how this works.
.P
@@ -19,9 +19,6 @@ directory. Similarly, debian/package.emacsen-remove is installed into
usr/lib/emacsen-common/packages/remove/package . And similarly,
debian/package.emacsen-startup is installed into
etc/emacs/site-start.d/50<package>.el (by default).
-.P
-For the first first binary package listed in the control file, you may use
-debian/emacsen-install, debian/emacsen-remove, and debian/emacsen-startup instead.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installexamples.1 b/dh_installexamples.1
index 650fabab..0bbf43a5 100644
--- a/dh_installexamples.1
+++ b/dh_installexamples.1
@@ -8,13 +8,12 @@ dh_installexamples \- install example files into package build directories
dh_installexamples is a debhelper program that is responsible for installing
examples into usr/share/doc/package/examples in package build directories.
.P
-Any file names specified as parameters will be installed into the first
-package dh_installexamples is told to act on. By default, this is the first
+Any file names specified as parameters will be installed into the first
+package dh_installexamples is told to act on. By default, this is the first
binary package in debian/control, but if you use -p, -i, or -a flags, it
will be the first package specified by those flags.
.P
-A file named debian/package.examples (debian/examples may be used for the
-first binary package in debian/control) can list other files to be installed.
+Files named debian/package.examples can list other files to be installed.
.SH OPTIONS
.TP
.B debhelper options
@@ -41,7 +40,8 @@ for a list of environment variables that affect all debhelper commands.
.BR debhelper (1)
.SH BUGS
It's impossible to specify filenames with spaces or other whitespace in them
-in debian/examples file. This is more a historical design flaw than a bug.
+in debian/package.examples file. This is more a historical design flaw than a
+bug.
.SH "CONFORMS TO"
Debian policy, version 3.0.1
.SH AUTHOR
diff --git a/dh_installinfo.1 b/dh_installinfo.1
index 324907d1..3728dab7 100644
--- a/dh_installinfo.1
+++ b/dh_installinfo.1
@@ -9,12 +9,11 @@ dh_installinfo is a debhelper program that is responsible for installing
info files and registering them with install-info.
.P
Any filenames specified as parameters will be installed into the first
-package dh_installinfo is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
+package dh_installinfo is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags, it
will be the first package specified by those flags.
.P
-A file named debian/package.info (debian/info may be used for the first
-binary package in debian/control) can list other files to be installed.
+Files named debian/package.info can list other files to be installed.
.P
dh_installinfo will automatically generate the postinst and prerm commands
needed to interface with install-info. See
@@ -51,7 +50,7 @@ between invocations of this command. Otherwise, it may cause multiple
instances of the same text to be added to maintainer scripts.
.SH BUGS
It's impossible to specify filenames with spaces or other whitespace in them
-in debian/info file. This is more a historical design flaw than a bug.
+in debian/package.info files. This is more a historical design flaw than a bug.
.SH "CONFORMS TO"
Debian policy, version 3.0.1
.SH AUTHOR
diff --git a/dh_installinit.1 b/dh_installinit.1
index d855e9e3..62966fe1 100644
--- a/dh_installinit.1
+++ b/dh_installinit.1
@@ -6,17 +6,15 @@ dh_installinit \- install init scripts into package build directories
.I "[debhelper options] [--init-script=scriptname] [-n] [-r] [-d] [-uparams] -- [params]"
.SH "DESCRIPTION"
dh_installinit is a debhelper program that is responsible for installing
-init scripts into package build directories.
+init scripts into package build directories.
.P
-It also automatically generates the postinst and postrm and prerm commands
+It also automatically generates the postinst and postrm and prerm commands
needed to set up the symlinks in /etc/rc*.d/ and to start and stop the init
scripts.
.P
-If a file named debian/package.init (or debian/package.init.d for backwards
-compatibility with debstd) exists, then it is installed into
+If a file named debian/package.init exists, then it is installed into
etc/init.d/package in the package build directory, with "package" replaced
-by the packagename. (You may use debian/init for the first binary package
-listed in the control file.)
+by the package name.
.SH OPTIONS
.TP
.B debhelper options
@@ -39,7 +37,7 @@ the --init-script parameter described below.)
.B \-uparams, \--update-rcd-params=params
.TP
.B \-\- params
-Pass "params" to
+Pass "params" to
.BR update-rc.d (8)
If not specified, "defaults" will be passed to
.BR update-rc.d (8)
@@ -50,7 +48,7 @@ etc/init.d/ . This is useful if you need to have an init script with a name
different from the package's name. Note that if you use this parameter,
dh_installinit will look to see if a file in the debian/ directory exists
that looks like "scriptname" or "package.scriptname" and if so will install
-it as the inist script in preference to the files it normally installs. This
+it as the init script in preference to the files it normally installs. This
feature is really only useful if you need a single package to install more
than one init script.
.SH ENVIRONMENT
diff --git a/dh_installlogrotate.1 b/dh_installlogrotate.1
index 1f522728..2cea36e0 100644
--- a/dh_installlogrotate.1
+++ b/dh_installlogrotate.1
@@ -7,10 +7,7 @@ dh_installlogrotate \- install logrotate config files
.SH "DESCRIPTION"
dh_installlogrotate is a debhelper program that is responsible for installing
logrotate config files into etc/logrotate.d in package build directories.
-The file debian/logrotate is installed. If your package generates multiple
-binary packages (or if you just prefer to do it), you can also use filenames
-like debian/package.logrotate, where "package" is replaced with the name of
-the binary package this logrotate config file goes into.
+Files named debian/package.logrotate are installed.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installmanpages.1 b/dh_installmanpages.1
index efd4afa2..d60430da 100644
--- a/dh_installmanpages.1
+++ b/dh_installmanpages.1
@@ -46,7 +46,7 @@ for a list of environment variables that affect all debhelper commands.
.SH BUGS
Man pages with the extension
.B .man
-are not automatically installed.
+are not automatically installed.
.P
Files specified as parameters that contain spaces in their filenames will
not be processed properly.
diff --git a/dh_installmenu.1 b/dh_installmenu.1
index e156110b..a1e10e83 100644
--- a/dh_installmenu.1
+++ b/dh_installmenu.1
@@ -6,10 +6,10 @@ dh_installmenu \- install debian menu files into package build directories
.I "[debhelper options] [-n]"
.SH "DESCRIPTION"
dh_installmenu is a debhelper program that is responsible for installing
-files used by the debian menu package into package build directories.
+files used by the debian menu package into package build directories.
.P
-It also automatically generates the postinst and postrm commands needed to
-interface with the debian menu package. See
+It also automatically generates the postinst and postrm commands needed to
+interface with the debian menu package. See
.BR dh_installdeb (1)
for an explanation of how this works.
.P
@@ -20,9 +20,6 @@ file.
If a file named debian/package.menu-method exits, then it is installed into
etc/menu-methods/package in the package build directory. This is a debian
menu method file.
-.P
-For the first first binary package listed in the control file, you may use
-debian/menu and debian/menu-method instead.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installmime.1 b/dh_installmime.1
index 54cf403d..f7059fbe 100644
--- a/dh_installmime.1
+++ b/dh_installmime.1
@@ -6,18 +6,15 @@ dh_installmime \- install mime files into package build directories
.I "[debhelper options] [-n]"
.SH "DESCRIPTION"
dh_installmime is a debhelper program that is responsible for installing
-mime files into package build directories.
+mime files into package build directories.
.P
-It also automatically generates the postinst and postrm commands needed to
-interface with the debian mime-support package. See
+It also automatically generates the postinst and postrm commands needed to
+interface with the debian mime-support package. See
.BR dh_installdeb (1)
for an explanation of how this works.
.P
If a file named debian/package.mime exists, then it is installed into
usr/lib/mime/packages/package in the package build directory.
-.P
-For the first first binary package listed in the control file, you may use
-debian/mime instead.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installmodules.1 b/dh_installmodules.1
index aee47d36..0f7627b8 100644
--- a/dh_installmodules.1
+++ b/dh_installmodules.1
@@ -8,15 +8,14 @@ dh_installmodules \- register modules with modutils
dh_installmodules is a debhelper program that is responsible for registering
kernel modules with modutils.
.P
-A file named debian/package.modules (debian/modules may be used for the first
-binary package in debian/control) will be installed as etc/modutils/package
+Files named debian/package.modules will be installed as etc/modutils/package
in the package build directory.
.P
Then postinst and postrm commands are automatically generated to register
the modules when the package is installed. See
.BR dh_installdeb (1)
for an explanation of how this works. Note that this will be done for any
-package this program acts on which has either the above-mentioned file, or
+package this program acts on which has either the above-mentioned file, or
has .o files in /lib/modules.
.SH OPTIONS
.TP
diff --git a/dh_installpam.1 b/dh_installpam.1
index 6bb219bb..31d0a933 100644
--- a/dh_installpam.1
+++ b/dh_installpam.1
@@ -6,13 +6,10 @@ dh_installpam \- install pam support files
.I "[debhelper options] [-n]"
.SH "DESCRIPTION"
dh_installpam is a debhelper program that is responsible for installing
-files used by PAM into package build directories.
+files used by PAM into package build directories.
.P
If a file named debian/package.pam exists, then it is installed into
etc/pam.d/package in the package build directory.
-.P
-For the first first binary package listed in the control file, you may use
-debian/pam instead.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_installwm.1 b/dh_installwm.1
index 33345a9d..88d29c81 100644
--- a/dh_installwm.1
+++ b/dh_installwm.1
@@ -11,12 +11,11 @@ with
.BR update-alternatives (8)
.P
Any windowmanager filenames specified as parameters will be registered in
-the first package dh_installwm is told to ast on. By default, this is the
+the first package dh_installwm is told to act on. By default, this is the
first binary package in debian/control, but if you use -p, -i, or -a flags, it
will be the first package specified by those flags.
.P
-A file named debian/package.wm (debian/wm may be used for the
-first binary package in debian/control) can list other window manager to
+Files named debian/package.wm can list other window managers programs to
register.
.SH OPTIONS
.TP
@@ -35,10 +34,6 @@ Do not modify postinst/postrm scripts. Turns this command into a no-op.
.TP
.B wmfilename
The filename of the window manager you wish to register.
-.SH NOTES
-Note that this command will set up postinst and postrm scripts for every
-package it acts on. It's wise to limit its action to a single package with,
-for example, the -p switch.
.SH ENVIRONMENT
See
.BR debhelper (1)
diff --git a/dh_installxaw.1 b/dh_installxaw.1
index 9e2632cb..809f0cd8 100644
--- a/dh_installxaw.1
+++ b/dh_installxaw.1
@@ -6,18 +6,15 @@ dh_installxaw \- install xaw wrappers config files into package build directorie
.I "[debhelper options] [-n]"
.SH "DESCRIPTION"
dh_installxaw is a debhelper program that is responsible for installing
-xaw wrappers config files into package build directories.
+xaw wrappers config files into package build directories.
.P
It also automatically generates the postinst, prerm, and postrm commands needed to
-interface with the debian xaw-wrappers package. See
+interface with the debian xaw-wrappers package. See
.BR dh_installdeb (1)
for an explanation of how this works.
.P
If a file named debian/package.xaw exists, then it is installed into
usr/lib/xaw-wrappers/config/package in the package build directory.
-.P
-For the first first binary package listed in the control file, you may use
-debian/xaw instead.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_link.1 b/dh_link.1
index 7da17504..017bfe5d 100644
--- a/dh_link.1
+++ b/dh_link.1
@@ -5,7 +5,7 @@ dh_link \- create symlinks in package build directories
.B dh_link
.I "[debhelper options] [-A] [source destination ...]"
.SH "DESCRIPTION"
-dh_link is a debhelper program that creates symlinks in package build
+dh_link is a debhelper program that creates symlinks in package build
directories.
.P
dh_link accepts a list of pairs of source and destination files. The source
@@ -15,13 +15,12 @@ destination files are the symlinks that will be created. There
be an equal number of source and destination files specified.
.P
The list can be specified in two ways. A file named debian/package.links
-(debian/links may be used for the first binary package in debian/control)
can list pairs of files. If you use this file, you should put each pair
of files on its own line, and separate the files within the pair with
whitespace. Also, pairs of files can be specified as parameters - these
pairs will only be created in the package build directory of the first
-ackage dh_link is told to act on. By default, this is the first binary
-package in debian/control, but if you use -p, -i, or -a flags, it will be
+ackage dh_link is told to act on. By default, this is the first binary
+package in debian/control, but if you use -p, -i, or -a flags, it will be
the first package specified by those flags.
.P
Be sure you
@@ -47,8 +46,8 @@ Create any links specified by command line parameters in ALL packages
acted on, not just the first.
.TP
.B source destination ...
-Create a file named "destination" as a link to a file named "source". Do
-this in the package build directory of the first package acted on.
+Create a file named "destination" as a link to a file named "source". Do
+this in the package build directory of the first package acted on.
(Or in all packages if -A is specified.)
.SH EXAMPLES
.TP
@@ -66,7 +65,8 @@ for a list of environment variables that affect all debhelper commands.
.BR debhelper (1)
.SH BUGS
It's impossible to specify filenames with spaces or other whitespace in them
-in debian/links file. This is more a historical design flaw than a bug.
+in debian/package.links files. This is more a historical design flaw than a
+bug.
.SH "CONFORMS TO"
Debian policy, version 3.0.1
.SH AUTHOR
diff --git a/dh_md5sums.1 b/dh_md5sums.1
index c23a04b6..cff1178d 100644
--- a/dh_md5sums.1
+++ b/dh_md5sums.1
@@ -9,7 +9,7 @@ dh_md5sums is a debhelper program that is responsible for generating
a DEBIAN/md5sums file, which lists the md5sums of each file in the package.
.P
All files in DEBIAN/ are omitted from the md5sums file, as are all conffiles
-(unless you use the -x switch).
+(unless you use the --include-conffiles switch).
.P
The md5sums file is installed with proper permissions and ownerships.
.SH OPTIONS
diff --git a/dh_movefiles.1 b/dh_movefiles.1
index 645e8263..f27b36f6 100644
--- a/dh_movefiles.1
+++ b/dh_movefiles.1
@@ -6,7 +6,7 @@ dh_movefiles \- move files out of debian/tmp into subpackages
.I "[debhelper options] [--sourcedir=dir] [file ..]"
.SH "DESCRIPTION"
dh_movefiles is a debhelper program that is responsible for moving files out
-of debian/tmp or some other directory and into other package build
+of debian/tmp or some other directory and into other package build
directories. This may be useful if your package has a Makefile that installs
everything into debian/tmp, and you need to break that up into subpackages.
.P
diff --git a/dh_perl.1 b/dh_perl.1
index 62156079..9f8bef8c 100644
--- a/dh_perl.1
+++ b/dh_perl.1
@@ -6,7 +6,7 @@ dh_perl \- calculates perl scripts & modules dependencies
.I "[debhelper options] [-k] [-d] [library dirs ...]"
.SH "DESCRIPTION"
dh_perl is a debhelper program that is responsible for generating
-the perl:Depends substitutions and adding them to substvars files.
+the perl:Depends substitutions and adding them to substvars files.
.P
The program will look for the location of installed modules and will
use this information to generate a dependency (at the present time
@@ -35,12 +35,12 @@ Keep .packlist files.
In some specific cases you may want to depend on a -base package
(ie perl-5.00X-base or perl5-base). If so, you can pass
the -d option to make
-.BR dh_perl
+.BR dh_perl
generate a dependency on the correct base package. This is only necessary
for some modules that are included in the base system.
.TP
.B library dirs
-If your package does install perl modules in non-standard
+If your package does install perl modules in non-standard
directories, you can make
.BR dh_perl
check those directories by passing their names on the command line.
diff --git a/dh_shlibdeps.1 b/dh_shlibdeps.1
index 1857d9dc..d09967a9 100644
--- a/dh_shlibdeps.1
+++ b/dh_shlibdeps.1
@@ -22,10 +22,10 @@ for a list of options common to all debhelper commands.
.B \-uparams, \--dpkg-shlibdeps-params=params
.TP
.B \-\- params
-Pass "params" to
+Pass "params" to
.BR dpkg-shlibdeps (1)
.TP
-.B \-Xitem, \--exclude=item
+.B \-Xitem, \--exclude=item
Exclude files that contain "item" anywhere in their filename from being
passed to dpkg-shlibdeps. This will make their dependancies be ignored.
This may be useful in some situations, but use it with caution. This option
diff --git a/dh_suidregister.1 b/dh_suidregister.1
index a4be7582..09da5123 100644
--- a/dh_suidregister.1
+++ b/dh_suidregister.1
@@ -7,17 +7,16 @@ dh_suidregister \- set up package to register files with suidregister
.SH "DESCRIPTION"
dh_suidregister is a debhelper program that is responsible for modifying the
postinst and postrm scripts of a package so the package will register files
-with
+with
.BR suidregister (1)
when it is installed.
.P
-Any filenames specified as parameters will be registered in the first
-package dh_suidregister is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags,
+Any filenames specified as parameters will be registered in the first
+package dh_suidregister is told to act on. By default, this is the first
+binary package in debian/control, but if you use -p, -i, or -a flags,
it will be the first package specified by those flags.
.P
-Files named debian/package.suid (or debian/suid for the first binary package
-in debian/control) can list other files to be registered.
+Files named debian/package.suid can list other files to be registered.
.P
If neither of these methods is used to specify files, dh_suidregister will
scan the package build directory for files that have suid permissions, and
diff --git a/dh_undocumented.1 b/dh_undocumented.1
index 5b6fab5e..98aaacf8 100644
--- a/dh_undocumented.1
+++ b/dh_undocumented.1
@@ -20,16 +20,15 @@ generates the necessary symlinks to
.BR undocumented (7)
, placing the sylinks in the package build directory.
.P
-The lists of man pages that need
+The lists of man pages that need
.BR undocumented (7)
symlinks can be specified in two ways. Any man page names specified as
parameters will be set up in the first package dh_undocumented is told
-to act on. By default, this is the first binary package in debian/control,
-but if you use -p, -i, or -a flags, it will be the first package specified
+to act on. By default, this is the first binary package in debian/control,
+but if you use -p, -i, or -a flags, it will be the first package specified
by those flags.
-Also, a file named debian/package.undocumented (or debian/undocumented, for
-the first binary package in debian/control) can list other man page names to
-set up.
+Also, a file named debian/package.undocumented can list other man page names
+to set up.
.SH OPTIONS
.TP
.TP
@@ -39,7 +38,7 @@ See
for a list of options common to all debhelper commands.
.TP
.B \-A, \--all
-Install undocumented man page symlinks for any man pages specified by
+Install undocumented man page symlinks for any man pages specified by
command line parameters in ALL packages acted on. I doubt anyone will find
this useful, it's here for consitency with other debhelper programs.
.TP
diff --git a/doc/TODO b/doc/TODO
index d16c7804..4cd09845 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -3,8 +3,6 @@ list grows - I welcome patches to fix items on it!
Wishlist items:
-* Move the perl libs into the correct perl lib dirs. Makes all debehelper
- scripts shorter..
* Make dh_* "use strict".
* Make dh_movefiles remove emptied directories after it's moved all the
files out of them (#17111).
@@ -67,6 +65,10 @@ Deprecated:
- currently, a few packages in potato use dh_du, but bugs have been filed.
* Remove support for --number option
- only dh_installemacsen ever used it, it is not --priority.
-* DH_COMPAT 1. Can be removed onve all packages are seen to be using 2 or
+* DH_COMPAT 1. Can be removed once all packages are seen to be using 2 or
higher. I won't hold my breath.
+* Also, grep the entire archive for all dh_* command lines, and check to
+ see what other switches are not being used, and maybe remove some of
+ them. I'd also like to depercate/remove debian/compress files, -X is
+ a better idea.