summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-01-22 02:35:15 +0000
committerjoey <joey>2001-01-22 02:35:15 +0000
commitf4f52f07ec3f5cebdd6d3bc6893f7025bad4d68f (patch)
tree25368fd502c7429ff14e0a2dfd21c6e807b8e96d
parent6d725d00f2b0794946f2f515791da40e442c62f0 (diff)
r409: * Corrected globbing issue with dh_movefiles in v3 mode. Closes: #81431
-rw-r--r--Debian/Debhelper/Dh_Lib.pm4
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdh_movefiles5
4 files changed, 14 insertions, 3 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index db2a1cf5..5373e808 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -131,6 +131,7 @@ sub xargs {
# The kernel can accept command lines up to 20k worth of characters.
my $command_max=20000; # LINUX SPECIFIC!!
+ # I could use POSIX::ARG_MAX, but that would be slow.
# Figure out length of static portion of command.
my $static_length=0;
@@ -353,12 +354,11 @@ sub filearray {
#
# The tricky bit is that the glob expansion is done
# as if we were in the specified directory, so the
- # filenames that come out are relative to it.
+ # filenames that come out are relative to it.
if (defined $globdir && ! compat(2)) {
for (map { glob "$globdir/$_" } split) {
s#^$globdir/##;
push @ret, $_;
- print "(--$_)\n";
}
}
else {
diff --git a/debian/changelog b/debian/changelog
index fa495347..4897016d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.2.14) unstable; urgency=medium
+
+ * Corrected globbing issue with dh_movefiles in v3 mode. Closes: #81431
+
+ -- Joey Hess <joeyh@debian.org> Sun, 21 Jan 2001 18:33:59 -0800
+
debhelper (2.2.13) unstable; urgency=medium
* Fixed a man page typo, Closes: #82371:
diff --git a/debian/control b/debian/control
index 07e9a424..54c7afea 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl-5.005, fileutils (>= 4.0-2.1), file (>= 3.23-1)
-Standards-Version: 3.2.1.0
+Standards-Version: 3.2.1.2
Package: debhelper
Architecture: all
diff --git a/dh_movefiles b/dh_movefiles
index be46dcb3..140f749a 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -50,6 +50,11 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
@tomove=@filelist;
}
+ else {
+ # However, filearray() does not add the sourcedir,
+ # which we need.
+ @tomove = map { "$sourcedir/$_" } @tomove;
+ }
if (@tomove) {
if (! -d $TMP) {