summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-11-14 16:00:08 +0000
committerjoey <joey>2002-11-14 16:00:08 +0000
commitfb6b68f1a6c5165da08afa0185d0ce8f8c5156d1 (patch)
tree8f514b7efa30e6409552f386a7344c4430d19ed3
parentd4d4af4fcb3f1d7f23f92b1847f8191efbb594ea (diff)
r562: * Make dh_install --list-missing honor -X excludes. Closes: #168739
* As a special case, if --sourcedir is not set (so is "."), make --list-missing look only at what is in debian/tmp. This is gross, but people have come to depend on that behavior, and that combination has no other sane meaning. Closes: #168751
-rw-r--r--debian/changelog10
-rwxr-xr-xdh_install8
2 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b21744d8..b1be5fdf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (4.1.21) unstable; urgency=low
+
+ * Make dh_install --list-missing honor -X excludes. Closes: #168739
+ * As a special case, if --sourcedir is not set (so is "."), make
+ --list-missing look only at what is in debian/tmp. This is gross, but
+ people have come to depend on that behavior, and that combination has no
+ other sane meaning. Closes: #168751
+
+ -- Joey Hess <joeyh@debian.org> Thu, 14 Nov 2002 10:56:21 -0500
+
debhelper (4.1.20) unstable; urgency=low
* typo in dh_shlibdeps(1), Closes: #167421
diff --git a/dh_install b/dh_install
index 33f24d06..afd5a264 100755
--- a/dh_install
+++ b/dh_install
@@ -79,8 +79,6 @@ you don't miss installing newly added files in new upstream releases.
Note that files that are excluded from being moved via the -X option are not
warned about.
-You need to use the --sourcedir parameter for this one to be of much use.
-
=item B<--sourcedir=dir>
Makes all source files be found under dir. If this is specified, it is
@@ -173,6 +171,12 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if ($dh{LIST_MISSING}) {
+
+ # . as srcdir makes no sense, so this is a special case.
+ if ($srcdir eq '.') {
+ $srcdir='debian/tmp';
+ }
+
my @missing;
my $installed=join("|", @installed);
$installed=qr{^$installed$};