summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-10-28 16:28:35 +0000
committerjoey <joey>2002-10-28 16:28:35 +0000
commitc0d066ddce232280756df9c5b218c3c6145001bb (patch)
treebf7940585514f7f5835f84766fd15a2115491dcc
parent79cd10da45b0324c7e8e18c4f7daffbd1d245fab (diff)
r559: * Added note to dh_installdebconf(1) about postinst sourcing debconf
confmodule. (Cf #106070) * Added an example to dh_install(1). Closes: #166402
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_install28
-rwxr-xr-xdh_installdebconf5
3 files changed, 37 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index c11d28c3..2549c768 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.19) unstable; urgency=low
+
+ * Added note to dh_installdebconf(1) about postinst sourcing debconf
+ confmodule. (Cf #106070)
+ * Added an example to dh_install(1). Closes: #166402
+
+ -- Joey Hess <joeyh@debian.org> Sun, 27 Oct 2002 20:26:02 -0500
+
debhelper (4.1.18) unstable; urgency=low
* Use dpkg-architecture instead of dpkg --print-architecture (again?)
diff --git a/dh_install b/dh_install
index 004e21f0..d6f1f1bc 100755
--- a/dh_install
+++ b/dh_install
@@ -56,7 +56,7 @@ specified, you should not list destination directories in
debian/package.install files or on the command line. Instead, dh_install
will guess as follows:
-Strip off debian/tmp from the front of the filename, of it is present, and
+Strip off debian/tmp from the front of the filename, if it is present, and
install into the dirname of the filename. So if the filename is
debian/tmp/usr/bin, then that directory will be copied to
debian/package/usr/. If the filename is debian/tmp/etc/passwd, it will be
@@ -81,9 +81,8 @@ warned about.
=item B<--sourcedir=dir>
-Makes all source files relative to "dir". If this is specified, it is akin
-to all the source files having "dir" prepended to them. By default, "dir"
-is '.'.
+Makes all source files be found under dir. If this is specified, it is akin
+to all the source filenames having "dir/" prepended to them.
To make dh_install behave like the old dh_movefiles, move your
package.files file to package.install and call dh_install with
@@ -185,6 +184,27 @@ if ($dh{LIST_MISSING}) {
}
}
+=head1 EXAMPLE
+
+Suppose your package's upstream Makefile installs a binary, a man page, and
+a library into appropriate subdirectories of debian/tmp. You want to put
+the library into package libfoo, and the rest into package foo. Your rules
+file will run "dh_install --sourcedir=debian/tmp". Make debian/foo.install
+contain:
+
+ usr/bin
+ usr/share/man/man1
+
+While debian/libfoo.install contains:
+
+ usr/libfoo*.so.*
+
+If you want a libfoo-dev package too, debian/libfoo-dev.install might contain:
+
+ usr/include
+ usr/lib/libfoo*.so
+ usr/share/man/man3
+
=head1 SEE ALSO
L<debhelper(1)>
diff --git a/dh_installdebconf b/dh_installdebconf
index be6fcabf..b11ca7d8 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -28,6 +28,11 @@ installed into the DEBIAN directory in the package build directory.
Note that if you use debconf, your package probably needs to depend on it
(it will be added to ${misc:Depends} by this program).
+Note that for your config script to be called by dpkg, your postinst
+needs to source debconf's confmodule. dh_installdebconf does not
+install this statement into postinst automatically as it it too hard to
+do it right.
+
=head1 LOCALIZED TEMPLATE FILES
Debconf also supports localized template files, and this program has some