summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-02-24 17:14:58 -0400
committerJoey Hess <joey@kitenet.net>2013-02-24 17:14:58 -0400
commit28bf03d222bd5c7b5e3e68db42b29d81ea7ae681 (patch)
tree6f3b2ea7979b098a6b50785840e938ce7cf13014
parente9fe3cee83cdcc4df978fb1761009dfc124add92 (diff)
cmake: Configure with -DCMAKE_BUILD_TYPE=RelWithDebInfo Closes: #701233
I'm told this only avoids building with -O3 -DNDEBUG, a change which should have no potential for breaking anything.
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm1
-rw-r--r--debian/changelog2
2 files changed, 3 insertions, 0 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 1d009b44..d47821ca 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -43,6 +43,7 @@ sub configure {
# Standard set of cmake flags
push @flags, "-DCMAKE_INSTALL_PREFIX=/usr";
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
+ push @flags, "-DCMAKE_BUILD_TYPE=RelWithDebInfo";
# CMake doesn't respect CPPFLAGS, see #653916.
if ($ENV{CPPFLAGS} && ! compat(8)) {
diff --git a/debian/changelog b/debian/changelog
index efe0f06a..6d32da53 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,6 +27,8 @@ debhelper (9.20120609) UNRELEASED; urgency=low
* dh_icons: Reword description. Closes: #693100
* Avoid find -perm +mode breakage caused by findutils 4.5.11,
by instead using -perm /mode. Closes: #700200
+ * cmake: Configure with -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ Closes: #701233
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600