summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-09-21 13:13:44 -0400
committerJoey Hess <joey@kitenet.net>2013-09-21 13:13:44 -0400
commit3647e4a32f4016b743ebf58d1e77abdbd5a245de (patch)
tree832c44ae91ec1a4285d402fccefc1f2c91d340da
parenta44e0e5706a5f83eb0211ac069cf45d6a877fb97 (diff)
dh_installchangelogs: Add changelog.md to the list of common changelog filenames.
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installchangelogs2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 88740b75..284e167a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ debhelper (9.20130721) UNRELEASED; urgency=low
* dh: Call dh_installxfonts after dh_link, so that it will
notice fonts installed via symlinks. Closes: #721264
* Fix FTBFS with perl 5.18. Closes: #722501
+ * dh_installchangelogs: Add changelog.md to the list of common
+ changelog filenames.
-- Joey Hess <joeyh@debian.org> Tue, 20 Aug 2013 12:46:25 -0400
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 74745720..2f65f8a7 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -142,7 +142,7 @@ if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
foreach my $dir (qw{. doc docs}) {
my @files=sort glob("$dir/*");
- foreach my $name (qw{changelog changes changelog.txt changes.txt history history.txt}) {
+ foreach my $name (qw{changelog changes changelog.txt changes.txt history history.txt changelog.md}) {
my @matches=grep {
lc basename($_) eq $name && -s $_ && ! excludefile($_)
} @files;