summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-03-17 16:15:06 -0400
committerJoey Hess <joey@kitenet.net>2013-03-17 16:15:06 -0400
commitc6b2671217ceba031664e5c5ad914f1c92f624c5 (patch)
tree8d4e95f0208d41402285e9da6111a4592849c2ac
parent28bf03d222bd5c7b5e3e68db42b29d81ea7ae681 (diff)
dh_auto_test: Avoid doing anything when cross-compiling. Closes: #703262
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_auto_test6
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d32da53..ae852e3e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,7 @@ debhelper (9.20120609) UNRELEASED; urgency=low
by instead using -perm /mode. Closes: #700200
* cmake: Configure with -DCMAKE_BUILD_TYPE=RelWithDebInfo
Closes: #701233
+ * dh_auto_test: Avoid doing anything when cross-compiling. Closes: #703262
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
diff --git a/dh_auto_test b/dh_auto_test
index 9d3fd93c..01dc5df5 100755
--- a/dh_auto_test
+++ b/dh_auto_test
@@ -47,9 +47,13 @@ B<dh_auto_test> usually passes.
If the B<DEB_BUILD_OPTIONS> environment variable contains B<nocheck>, no
tests will be performed.
+dh_auto_test does not run the test suite when a package is being cross
+compiled.
+
=cut
-if (get_buildoption("nocheck")) {
+if (get_buildoption("nocheck")
+ || (dpkg_architecture_value("DEB_HOST_GNU_TYPE") ne dpkg_architecture_value("DEB_BUILD_GNU_TYPE"))) {
exit 0;
}