summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Beckmann <anbe@debian.org>2013-12-13 01:18:28 +0100
committerJoey Hess <joey@kitenet.net>2013-12-13 13:00:47 -0400
commiteaaa4d05f4cfabbb4da37e7caf2029e821787dc3 (patch)
tree90ec998ec3b060ef13b39d085dcfec09b92c289f
parent7912710d34b8001959e9ffee079fcf5dffdf0007 (diff)
dh_installdeb: add support for d-m-h commands symlink_to_dir, dir_to_symlink
these two new dpkg-maintscript-helper commands were added in dpkg 1.17.2 (and fixed in 1.17.5, therefore using this version for Pre-Depends)
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installdeb2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 526ca9fa..ffdc5b19 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
debhelper (9.20131128) UNRELEASED; urgency=low
+ [ Joey Hess ]
* cmake: Configure with -DCMAKE_BUILD_TYPE=None
Closes: #701233
+ [ Andreas Beckmann ]
+ * dh_installdeb: Add support for dpkg-maintscript-helper commands
+ symlink_to_dir and dir_to_symlink that were added in dpkg 1.17.2.
+ Closes: #731723
+
-- Joey Hess <joeyh@debian.org> Thu, 05 Dec 2013 14:04:01 -0400
debhelper (9.20131127) unstable; urgency=low
diff --git a/dh_installdeb b/dh_installdeb
index e2331701..1f02edf4 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -69,6 +69,8 @@ init();
my %maintscript_predeps = (
"rm_conffile" => "",
"mv_conffile" => "",
+ "symlink_to_dir" => "1.17.5",
+ "dir_to_symlink" => "1.17.5",
);
foreach my $package (@{$dh{DOPACKAGES}}) {