summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-05-21 15:25:49 -0400
committerJoey Hess <joey@kitenet.net>2011-05-21 15:37:58 -0400
commit5e13cc10b6c899fa143b76d4b312b7cdb2e39d08 (patch)
tree8a375bfe1c716044e38d585d2d29f27ea04f7c90
parentfbe972f2a63a1dd6d7a49c63cb705e688adf27f0 (diff)
Fix example. Closes: #627534
-rw-r--r--debian/changelog6
-rwxr-xr-xdh11
2 files changed, 13 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 9fd5122b..677165aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (8.1.7) UNRELEASED; urgency=low
+
+ * Fix example. Closes: #627534
+
+ -- Joey Hess <joeyh@debian.org> Sat, 21 May 2011 15:24:19 -0400
+
debhelper (8.1.6) unstable; urgency=low
* dh_ucf: Fix missing space before ']'s in postrm autoscript.
diff --git a/dh b/dh
index 921ef558..50e0f14d 100755
--- a/dh
+++ b/dh
@@ -240,16 +240,19 @@ L<dh_listpackages(1)> to test what is being built. For example:
endif
Finally, remember that you are not limited to using override targets in the
-rules file when using B<dh>. You can also explicitly define any of the regular
+rules file when using B<dh>. You can also explicitly define the regular
rules file targets when it makes sense to do so. A common reason to do this
-is if your package needs different B<build-arch> and B<build-indep> targets. For
-example, a package with a long document build process can put it in
-B<build-indep> to avoid build daemons redundantly building the documentation.
+is if your package needs different B<build-arch> and B<build-indep> targets.
+For example, a package with a long document build process can put it in
+B<build-indep>.
#!/usr/bin/make -f
%:
dh $@
+ binary: binary-arch binary-indep ;
+ binary-arch:: build-arch
+ binary-indep:: build-indep
build: build-arch build-indep ;
build-indep:
$(MAKE) docs