summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-12-08 19:36:38 -0400
committerJoey Hess <joey@kitenet.net>2011-12-08 19:36:38 -0400
commit71815c9c6ea75ac779d1ff50e7a285c0d9f13bd0 (patch)
tree5870e392388b78caac4e387edd4ee305fabdb9fd
parent35260f3162622e69270028cb5c56a080f32d8556 (diff)
only v9
Reason: http://git.42mm.org/?p=python-greenlet;a=blob;f=debian/rules;h=bd009f86895d496999cd412eac44dbae7b9f1caa;hb=HEAD#l10
-rw-r--r--debhelper.pod5
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_strip4
3 files changed, 8 insertions, 3 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 65616e39..72234ca7 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -509,6 +509,11 @@ they are already set. They support DEB_BUILD_OPTIONS=noopt too.
B<dh_auto_configure> passes CFLAGS to perl F<Makefile.PL> and
F<Build.PL>
+=item -
+
+B<dh_strip> puts separated debug symbols in a location based on their
+build-id.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 74f5bc40..43c9d4a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,7 @@
debhelper (8.9.13) UNRELEASED; urgency=low
* Pass CPPFLAGS to qmake. Closes: #646129 Thanks, Felix Geyert
- * dh_strip: Use build-id in /usr/lib/debug.
+ * dh_strip: Use build-id in /usr/lib/debug in v9.
Closes: #642158 Thanks, Jakub Wilk
* Spanish translation update. Closes: #636245 Thanks, Omar Campagne
diff --git a/dh_strip b/dh_strip
index be0b000d..57c45f5c 100755
--- a/dh_strip
+++ b/dh_strip
@@ -162,8 +162,8 @@ sub make_debug {
my ($base_file)=$file=~/^\Q$tmp\E(.*)/;
my $debug_path;
- my $elfnotes=`readelf -n $file`;
- if ($elfnotes =~ /^\s+Build ID: ([0-9a-f]{2})([0-9a-f]+)$/m) {
+ if (! compat(8) &&
+ `readelf -n $file`=~ /^\s+Build ID: ([0-9a-f]{2})([0-9a-f]+)$/m) {
$debug_path=$desttmp."/usr/lib/debug/.build-id/$1/$2.debug"
}
else {