summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-09-09 14:28:51 -0400
committerJoey Hess <joey@kitenet.net>2012-09-09 14:29:26 -0400
commit073034791eea9df519a06deb4058908e30d0fa7d (patch)
tree579c525c079efe0e1b50621e10f5055a6ba42f3a
parentf7c9099e88846f7c117aa592f5119911f03e71e5 (diff)
parent37de53703877f57f1604038706a7dce3e292c3ad (diff)
Merge branch 'wheezy'
-rw-r--r--Debian/Debhelper/Dh_Lib.pm23
-rw-r--r--debian/changelog11
-rw-r--r--doc/PROGRAMMING9
-rwxr-xr-xt/dh-lib31
4 files changed, 68 insertions, 6 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 10ae69f7..7b550b0e 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -504,7 +504,8 @@ sub pkgfilename {
# 1: package
# 2: script to add to
# 3: filename of snippet
-# 4: sed to run on the snippet. Ie, s/#PACKAGE#/$PACKAGE/
+# 4: either text: shell-quoted sed to run on the snippet. Ie, 's/#PACKAGE#/$PACKAGE/'
+# or a sub to run on each line of the snippet. Ie sub { s/#PACKAGE#/$PACKAGE/ }
sub autoscript {
my $package=shift;
my $script=shift;
@@ -533,18 +534,34 @@ sub autoscript {
&& !compat(5)) {
# Add fragments to top so they run in reverse order when removing.
complex_doit("echo \"# Automatically added by ".basename($0)."\"> $outfile.new");
- complex_doit("sed \"$sed\" $infile >> $outfile.new");
+ autoscript_sed($sed, $infile, "$outfile.new");
complex_doit("echo '# End automatically added section' >> $outfile.new");
complex_doit("cat $outfile >> $outfile.new");
complex_doit("mv $outfile.new $outfile");
}
else {
complex_doit("echo \"# Automatically added by ".basename($0)."\">> $outfile");
- complex_doit("sed \"$sed\" $infile >> $outfile");
+ autoscript_sed($sed, $infile, $outfile);
complex_doit("echo '# End automatically added section' >> $outfile");
}
}
+sub autoscript_sed {
+ my $sed = shift;
+ my $infile = shift;
+ my $outfile = shift;
+ if (ref($sed) eq 'CODE') {
+ open(IN, $infile) or die "$infile: $!";
+ open(OUT, ">>$outfile") or die "$outfile: $!";
+ while (<IN>) { $sed->(); print OUT }
+ close(OUT) or die "$outfile: $!";
+ close(IN) or die "$infile: $!";
+ }
+ else {
+ complex_doit("sed \"$sed\" $infile >> $outfile");
+ }
+}
+
# Removes a whole substvar line.
sub delsubstvar {
my $package=shift;
diff --git a/debian/changelog b/debian/changelog
index 3b34f9c3..3f85493a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,6 +20,17 @@ debhelper (9.20120609) UNRELEASED; urgency=low
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
+debhelper (9.20120909) UNRELEASED; urgency=low
+
+ * autoscript() can now be passed a perl sub to run to s/// lines of
+ the script, which avoids problems with using sed, including potentially
+ building too long a sed command-line. This will become the recommended
+ interface in the future; for now it can be used by specific commands
+ such as dh_installxmlcatalogs that encounter the problem.
+ Closes: #665296 Thanks, Marcin Owsiany
+
+ -- Joey Hess <joeyh@debian.org> Sun, 09 Sep 2012 14:23:10 -0400
+
debhelper (9.20120830) unstable; urgency=low
* dh_installcatalogs: Adjust catalog conffile conversion to avoid
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index bcf1c13c..e1440c91 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -191,13 +191,16 @@ isnative($package)
is a native debian package.
As a side effect, $dh{VERSION} is set to the version number of the
package.
-autoscript($package, $scriptname, $snippetname, $sedcommands)
+autoscript($package, $scriptname, $snippetname, $sedcommands || $sub)
Pass parameters:
- binary package to be affected
- script to add to
- filename of snippet
- - sed commands to run on the snippet. Ie, s/#PACKAGE#/$PACKAGE/
- (optional) Note: Passed to the shell inside double quotes.
+ - (optional) EITHER sed commands to run on the snippet. Ie,
+ s/#PACKAGE#/$PACKAGE/ Note: Passed to the shell inside double
+ quotes.
+ OR a perl sub to invoke with $_ set to each line of the snippet in
+ turn.
This command automatically adds shell script snippets to a debian
maintainer script (like the postinst or prerm).
Note that in v6 mode and up, the snippets are added in reverse
diff --git a/t/dh-lib b/t/dh-lib
new file mode 100755
index 00000000..772b1a1e
--- /dev/null
+++ b/t/dh-lib
@@ -0,0 +1,31 @@
+#!/usr/bin/perl
+package Debian::Debhelper::Dh_Lib::Test;
+use strict;
+use warnings;
+use Test::More;
+
+plan(tests => 10);
+
+use_ok('Debian::Debhelper::Dh_Lib');
+
+sub ok_autoscript_result {
+ ok(-f 'debian/testpackage.postinst.debhelper');
+ open(F, 'debian/testpackage.postinst.debhelper') or die;
+ my (@c) = <F>;
+ close(F) or die;
+ like(join('',@c), qr{update-rc\.d test-script test parms with"quote >/dev/null});
+}
+
+ok(unlink('debian/testpackage.postinst.debhelper') >= 0);
+
+ok(autoscript('testpackage', 'postinst', 'postinst-init',
+ 's/#SCRIPT#/test-script/g; s/#INITPARMS#/test parms with\\"quote/g'));
+ok_autoscript_result;
+
+ok(unlink('debian/testpackage.postinst.debhelper') >= 0);
+
+ok(autoscript('testpackage', 'postinst', 'postinst-init',
+ sub { s/#SCRIPT#/test-script/g; s/#INITPARMS#/test parms with"quote/g } ));
+ok_autoscript_result;
+
+ok(unlink('debian/testpackage.postinst.debhelper') >= 0);