summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-12-08 18:08:52 +0000
committerjoey <joey>2005-12-08 18:08:52 +0000
commit084815258f457f7a41934549b52a63ba34b759e1 (patch)
treec8a6b184b02e3576ef8aaf30c50a36ed153fa82e
parentbbf4a3e5e7874150370b5d3ececb722686d1d732 (diff)
r1827: releasing version 5.0.9
-rw-r--r--autoscripts/postinst-modules7
-rw-r--r--autoscripts/postrm-modules1
-rw-r--r--debian/changelog8
-rw-r--r--man/po4a/po/debhelper.pot2
4 files changed, 15 insertions, 3 deletions
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index 8d2c4cbc..11c206bc 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,3 +1,6 @@
-if [ "$1" = "configure" ] && [ -x "`which update-modules 2>/dev/null`" ]; then
- update-modules >/dev/null || [ "$?" = 3 ]
+if [ "$1" = "configure" ]; then
+ if [ -x "`which update-modules 2>/dev/null`" ]; then
+ update-modules >/dev/null || [ "$?" = 3 ]
+ fi
+ depmod -a || true
fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index 35db8718..bcacb9f5 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1,3 +1,4 @@
if [ -x "`which update-modules 2>/dev/null`" ]; then
update-modules >/dev/null || [ "$?" = 3 ]
fi
+depmod -a || true
diff --git a/debian/changelog b/debian/changelog
index 952ee01d..30e54ea4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (5.0.9) unstable; urgency=low
+
+ * dh_installmodules: always run depmod, since if module-init-tools but not
+ modutils is installed, it will not get run by update-modules.
+ Closes: #339658
+
+ -- Joey Hess <joeyh@debian.org> Thu, 8 Dec 2005 13:04:11 -0500
+
debhelper (5.0.8) unstable; urgency=low
* Man page type fixes (yes, more, nice to know people read the man pages).
diff --git a/man/po4a/po/debhelper.pot b/man/po4a/po/debhelper.pot
index e7e40809..765f2deb 100644
--- a/man/po4a/po/debhelper.pot
+++ b/man/po4a/po/debhelper.pot
@@ -6,7 +6,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2005-12-05 14:32-0500\n"
+"POT-Creation-Date: 2005-12-08 13:05-0500\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"