summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2007-09-13 19:48:50 +0000
committerjoeyh <joeyh>2007-09-13 19:48:50 +0000
commit09bf5892fcc47c94d77c8457b533643ec3b58ef8 (patch)
treebf4bd20d7f162e91118a52b196e8092a087e4326
parent2edd22215ace8da90de46142b3b38896ee0aed72 (diff)
r2026: * dh_strip: Don't run objcopy if the output file already exists.
Closes: #380314
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_strip4
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d0cc7a11..d8d86b59 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,10 @@ debhelper (5.0.55) UNRELEASED; urgency=low
* dh_desktop: Only generate calls to update-desktop-database for desktop
files with MimeType fields. Patch from Emmet Hikory. Closes: #427831
+ * dh_strip: Don't run objcopy if the output file already exists.
+ Closes: #380314
- -- Joey Hess <joeyh@debian.org> Thu, 13 Sep 2007 15:11:06 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 13 Sep 2007 15:47:55 -0400
debhelper (5.0.54) unstable; urgency=low
diff --git a/dh_strip b/dh_strip
index e4e06984..ef91d651 100755
--- a/dh_strip
+++ b/dh_strip
@@ -156,7 +156,9 @@ sub make_debug {
if (! -d $debug_dir) {
doit("install", "-d", $debug_dir);
}
- doit("objcopy", "--only-keep-debug", $file, $debug_path);
+ if (! -e $debug_path) {
+ doit("objcopy", "--only-keep-debug", $file, $debug_path);
+ }
# No reason for this to be executable.
doit("chmod", 644, $debug_path);
return $debug_path;