summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2004-12-08 19:58:15 +0000
committerjoey <joey>2004-12-08 19:58:15 +0000
commit0a9afa6c5a1d57d596aa07d32052661ff146d3bf (patch)
tree6ec4a4cbd0a14926d318fe10ff1dbf92f791c8ad
parent257593ffa0765054c936527a0a4e36c7c3097f7b (diff)
r1728: releasing version 4.2.26
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installdocs11
-rwxr-xr-xdh_python8
-rw-r--r--man/es/dh_makeshlibs.pod45
4 files changed, 51 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a63739..67ebbd1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.2.26) unstable; urgency=low
+
+ * dh_makeshlibs spanish translation update
+ * Add example to dh_installdocs man page. Closes: #283857
+ * Clarify dh_python's documentation of -V and error if the version is
+ unknown. Closes: #282924
+
+ -- Joey Hess <joeyh@debian.org> Wed, 8 Dec 2004 14:44:44 -0500
+
debhelper (4.2.25) unstable; urgency=low
* dh_shlibdeps: Only set LD_LIBRARY_PATH when calling dpkg-shlibdeps.
diff --git a/dh_installdocs b/dh_installdocs
index ab7e53c..b694d7c 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -73,6 +73,17 @@ in all packages if B<-A> is specified).
=back
+=head1 EXAMPLES
+
+This is an example of a debian/package.docs file:
+
+ README
+ TODO
+ debian/notes-for-maintainers.txt
+ docs/manual.txt
+ docs/manual.pdf
+ docs/manual-html/
+
=head1 NOTES
Note that dh_installdocs will happily copy entire directory hierarchies if
diff --git a/dh_python b/dh_python
index eb32fd4..9fbedc4 100755
--- a/dh_python
+++ b/dh_python
@@ -50,9 +50,8 @@ extra names on the command line are searched for binary (.so) modules.
=item B<-V> I<version>
If the .py files your package ships are meant to be used by a specific
-pythonX.Y version, you can set this option with the desired X.Y python
-version.
-Do not use if you ship modules in /usr/lib/site-python.
+pythonX.Y version, you can use this option to specify the desired version,
+such as 2.3. Do not use if you ship modules in /usr/lib/site-python.
=item B<-n>, B<--noscripts>
@@ -99,6 +98,9 @@ my $usepython = "python$python_version";
if($dh{V_FLAG_SET}) {
$usepython = $dh{V_FLAG};
$usepython =~ s/^/python/;
+ if (! grep { $_ eq $usepython } @python_allversions) {
+ error("Unknown python version $dh{V_FLAG}");
+ }
}
# Cleaning the paths given on the command line
diff --git a/man/es/dh_makeshlibs.pod b/man/es/dh_makeshlibs.pod
index e0ed872..ce64247 100644
--- a/man/es/dh_makeshlibs.pod
+++ b/man/es/dh_makeshlibs.pod
@@ -2,7 +2,7 @@
# Esta traducción ha sido realizada por Rudy Godoy <rudy@kernel-panik.org>
# y revisada por Rubén Porras <nahoo@inicia.es>
# Está basada en la página de manual original:
-# versión 1.2 del CVS de
+# versión 1.3 del CVS de
# /cvs/debian-doc/manpages/english/debhelper/dh_makeshlibs.pod
=head1 NOMBRE
@@ -29,7 +29,7 @@ compartidas.
=item B<-m>I<mayor>, B<--major=>I<mayor>
-En lugar de tratar de adivinar el número mayor de la biblioteca con
+En lugar de intentar adivinar el número mayor de la biblioteca usando
objdump, usa el número mayor especificado después del parámetro -m. Esto
es mucho menos útil de lo que era antiguamente cuando este programa
buscaba los nombres de fichero de las bibliotecas en lugar de usar
@@ -41,20 +41,25 @@ objdump.
Por omisión, el fichero shlibs generado por este programa no hace que los
paquetes dependan de alguna versión particular del paquete que contiene la
-biblioteca compartida. Podría ser necesario para usted añadir alguna
-información de dependencia de versión al fichero shlibs. Si -V es especificado
-sin información de dependencia, la versión actual del paquete es conectada
-en una dependencia de la forma "nombre_de_paquete (>= versión_de_paquete)".
-Si -V es especificado con parámetros, los parámetros pueden ser usados para
-especificar la información de dependencia exacta necesitada (asegúrese de
-incluir el nombre del paquete).
-
-Tenga cuidado al usar -V sin ningún parámetro; ésta es una configuración
+biblioteca compartida. Podría ser necesario para usted el añadir alguna
+información de dependencia de versión al fichero shlibs. Si se especifica
+«-V» sin información de dependencia, la versión actual de desarrollador
+principal del paquete es conectada en una dependencia de la forma
+«nombre_de_paquete (>= versión_de_paquete)». Tenga en cuenta que en los
+niveles de compatibilidad de debhelper anteriores a v4, también se incluye
+la parte debian del número de versión del paquete. Si se especifica «-V»
+con parámetros, los parámetros pueden ser usados para especificar la
+información de dependencia exacta requerida (asegúrese de incluir el nombre
+del paquete).
+
+Tenga cuidado al usar «-V» sin ningún parámetro; ésta es una configuración
conservadora que siempre se asegura que las dependencias de bibliotecas
-compartidas de otros paquetes son al menos lo mas pequeñas que necesitan
-ser, de modo que si el desarrollador las malogra éstas no se romperán.
+compartidas de otros paquetes son al menos lo más pequeñas que necesitan
+ser (a menos que su biblioteca sea propensa a cambiar el ABI sin actualizar
+el número de versión del desarrollador principal), de modo que si el
+desarrollador las malogra éstas no se romperán.
Por otro lado los paquetes podrían terminar con dependencias muy rigurosas
-que harían difícil la actualización.
+que harían difícil su actualización.
=item B<-n>, B<--noscripts>
@@ -69,19 +74,21 @@ directorio de ser tratados como bibliotecas compartidas.
=head1 EJEMPLOS
- dh_makeshlibs
+=over 4
+
+=item dh_makeshlibs
Asumiendo que este es un paquete llamado libfoobar1, genera un fichero shlibs
que se ve como:
libfoobar 1 libfoobar1
- dh_makeshlibs -V
+=item dh_makeshlibs -V
-Asumiendo que la versión actual del paquete es 1.0-3, genera un fichero shlibs
+Asumiendo que la versión actual del paquete es 1.1-3, genera un fichero shlibs
que se ve como:
- libfoobar 1 libfoobar1 (>= 1.0-3)
+ libfoobar 1 libfoobar1 (>= 1.1)
- dh_makeshlibs -V 'libfoobar1 (>= 1.0)'
+=item dh_makeshlibs -V 'libfoobar1 (>= 1.0)'
Genera un fichero shlibs que se ve como:
libfoobar 1 libfoobar1 (>= 1.0)