summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-10-25 14:40:29 -0400
committerJoey Hess <joey@kitenet.net>2012-10-25 14:40:29 -0400
commit0bccbeee4e1e13fcd3553fcd7eabd9b3a7695690 (patch)
treef4a7e6cfb309eb1be5a769bd728680472df3f62a
parentf79ed4ddd81b299fe9b7aab55c0ef01b89989910 (diff)
dh_installdeb: Avoid unnecessary is_udeb tests. Closes: #691398
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_installdeb18
2 files changed, 10 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index b977faf7..af05a850 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -21,6 +21,7 @@ debhelper (9.20120609) UNRELEASED; urgency=low
Closes: #525821 Thanks, Don Armstrong
* dh_installinit: Support systemd.
Closes: #690399 Thanks, Michael Stapelberg
+ * dh_installdeb: Avoid unnecessary is_udeb tests. Closes: #691398
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
diff --git a/dh_installdeb b/dh_installdeb
index def76d16..bc4091b7 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -93,7 +93,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$f, "$tmp/DEBIAN/$script");
}
}
- next;
+
+ # stop here for udebs
+ next;
}
my $maintscriptfile=pkgfile($package, "maintscript");
@@ -117,19 +119,17 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
debhelper_script_subst($package, $script);
}
- if (! is_udeb($package)) {
- # Install non-executable files
- foreach my $file (qw{shlibs conffiles triggers}) {
- my $f=pkgfile($package,$file);
- if ($f) {
- doit("install","-o",0,"-g",0,"-m",644,"-p",$f,"$tmp/DEBIAN/$file");
- }
+ # Install non-executable files
+ foreach my $file (qw{shlibs conffiles triggers}) {
+ my $f=pkgfile($package,$file);
+ if ($f) {
+ doit("install","-o",0,"-g",0,"-m",644,"-p",$f,"$tmp/DEBIAN/$file");
}
}
# Automatic conffiles registration: If it is in /etc, it is a
# conffile.
- if (! compat(2) && -d "$tmp/etc" && ! is_udeb($package)) {
+ if (! compat(2) && -d "$tmp/etc") {
complex_doit("find $tmp/etc -type f -printf '/etc/%P\n' >> $tmp/DEBIAN/conffiles");
# Anything found?
if (-z "$tmp/DEBIAN/conffiles") {