summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-12 19:03:50 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-03-12 19:03:50 -0400
commit121a54e21f8bfa6784b2e8c40171e4800ffd1718 (patch)
treebfcab0f467e305254ff0f391a217e16112929e29
parent3215b78589e1b75ecaed40796effd119b323946c (diff)
dh_auto_test: Support DEB_BUILD_OPTIONS=nocheck. Closes: #519374
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_auto_test9
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 37eff5c0..9f7ee041 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ debhelper (7.2.6) UNRELEASED; urgency=low
* Examples files updated to add dh_bugfiles, remove obsolete
dh_python.
+ * dh_auto_test: Support DEB_BUILD_OPTIONS=nocheck. Closes: #519374
-- Joey Hess <joeyh@debian.org> Thu, 12 Mar 2009 19:00:35 -0400
diff --git a/dh_auto_test b/dh_auto_test
index baccd10a..ea2d7fdc 100755
--- a/dh_auto_test
+++ b/dh_auto_test
@@ -37,10 +37,19 @@ or override the any standard parameters that dh_auto_test passes.
=back
+=head1 NOTES
+
+If the DEB_BUILD_OPTIONS environment variable contains "nocheck", no
+tests will be performed.
+
=cut
init();
+if (defined $ENV{DEB_BUILD_OPTIONS} && $ENV{DEB_BUILD_OPTIONS} =~ /nocheck/) {
+ exit 0;
+}
+
if (-e "Makefile" || -e "makefile" || -e "GNUmakefile") {
$ENV{MAKE}="make" unless exists $ENV{MAKE};
foreach my $target (qw{test check}) {