summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2004-05-13 14:28:26 +0000
committerjoey <joey>2004-05-13 14:28:26 +0000
commit12ab9123302a20f471a1f329e65528fa6645c342 (patch)
tree41d56b1355e732a89fa75f7e57a6b7b00f1a9c9c
parent495e739006e509f7183b27d160dc6aa81e4f3db5 (diff)
r1687: * dh_installmodules: Look for .ko files too. Closes: #248624
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installmodules6
2 files changed, 9 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 21a75533..98b10d32 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.2.11) UNRELEASED; urgency=low
+
+ * dh_installmodules: Look for .ko files too. Closes: #248624
+
+ -- Joey Hess <joeyh@debian.org> Thu, 13 May 2004 11:25:42 -0300
+
debhelper (4.2.10) unstable; urgency=low
* dh_strip: if an .a file is not a binary file, do not try to strip it.
diff --git a/dh_installmodules b/dh_installmodules
index 71a0d1ce..28f947ca 100755
--- a/dh_installmodules
+++ b/dh_installmodules
@@ -27,7 +27,7 @@ Then postinst and postrm commands are automatically generated to register
the modules when the package is installed. See L<dh_installdeb(1)> for an
explanation of how this works. Note that this will be done for any
package this program acts on which has either the above-mentioned file, or
-has .o files in /lib/modules.
+has .o or .ko files in /lib/modules.
=head1 OPTIONS
@@ -56,13 +56,13 @@ instances of the same text to be added to maintainer scripts.
init();
-# Returns true if there are any .o files in the passed directory.
+# Returns true if there are any .o or .ko files in the passed directory.
sub find_kernel_modules {
my $searchdir=shift;
my @results=();
return unless -d $searchdir;
- find(sub { push @results, $_ if /\.o$/ }, $searchdir);
+ find(sub { push @results, $_ if /\.k?o$/ }, $searchdir);
return @results > 0;
}