summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-07-20 14:09:02 +0000
committerjoey <joey>2005-07-20 14:09:02 +0000
commit1b4a4bb37859d047d31e36fca733e7828377fd85 (patch)
treea82002953790774a85d634cf35f2d8ffd56ad39b
parentc64e5bced6f7114f228d90e2857b0ebb9bbf3baa (diff)
r1776: * dh_usrlocal: generate prerm scripts that do not remove distroties in
/usr/local, but only subdirectories thereof, in accordance with policy. Closes: #319181
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_usrlocal1
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 33b11ca2..f0ec9c36 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,11 @@ debhelper (4.9.5) UNRELEASED; urgency=low
* dh_install: in v5 mode, error out if there are wildcards in the file
list and the wildcards expand to nothing. Done only for v5 as this is a
behavior change. Closes: #249815
+ * dh_usrlocal: generate prerm scripts that do not remove distroties in
+ /usr/local, but only subdirectories thereof, in accordance with policy.
+ Closes: #319181
- -- Joey Hess <joeyh@debian.org> Tue, 19 Jul 2005 13:48:52 -0400
+ -- Joey Hess <joeyh@debian.org> Wed, 20 Jul 2005 10:08:05 -0400
debhelper (4.9.4) unstable; urgency=low
diff --git a/dh_usrlocal b/dh_usrlocal
index da709491..edfc0aa1 100755
--- a/dh_usrlocal
+++ b/dh_usrlocal
@@ -99,6 +99,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# This constructs the body of a 'sed' c\ expression which
# is parsed by the shell in double-quotes
my $dirs = join("$ebs\n", @dirs);
+ pop @justdirs; # don't remove directories in /usr/local
my $justdirs = join("$ebs\n", @justdirs);
if (! $dh{NOSCRIPTS}) {
autoscript($package,"postinst", "postinst-usrlocal",