summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-08-07 11:51:39 -0400
committerJoey Hess <joey@kitenet.net>2010-08-07 11:51:39 -0400
commit1f012ae1f98220de04be307beeb74eac80ab451c (patch)
treea0d4d8cc6b7fc8eefa5256da9086f85a6684e323
parentf35b15c9252dda49642d1f96f5c3d5587cfcff14 (diff)
python_distutils: Pass --force to setup.py build, to ensure that when python-dbg is run it does not win and result in scripts having it in the shebang line. Closes: #589759
(cherry picked from commit 865e6266a5eaae81004bf530bc23da1c3fdc10b1) Conflicts: debian/changelog
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm4
-rw-r--r--debian/changelog8
2 files changed, 11 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 70307b0f..5115a8ae 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -163,7 +163,9 @@ sub setup_py {
sub build {
my $this=shift;
- $this->setup_py("build", @_);
+ $this->setup_py("build",
+ "--force",
+ @_);
}
sub install {
diff --git a/debian/changelog b/debian/changelog
index 54ec7a04..8a2016c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (8.1.0) UNRELEASED; urgency=low
+
+ * python_distutils: Pass --force to setup.py build, to ensure that when
+ python-dbg is run it does not win and result in scripts having it in
+ the shebang line. Closes: #589759
+
+ -- Joey Hess <joeyh@debian.org> Sat, 07 Aug 2010 11:27:24 -0400
+
debhelper (8.0.0) unstable; urgency=low
[ Carsten Hey ]