summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2009-08-08 16:11:59 -0400
committerJoey Hess <joey@kitenet.net>2009-08-08 16:11:59 -0400
commit1f7c1372cfd161f056d0a7355c1309d1d90a0acb (patch)
tree5782b10e2ef55b6cce67f77b7d0dc5dce3a6b209
parent50fb7898bb603e07429d42d181fc9525b83b233f (diff)
parent16b20dfd69af55f312f21a98d1344252ae179238 (diff)
Merge branch 'master' of ssh://git.debian.org/git/debhelper/debhelper
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm19
-rw-r--r--debian/changelog11
2 files changed, 27 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4838cada..4dc2a0d9 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -114,7 +114,7 @@ sub setup_py {
# Take into account that the default Python must not be in
# the requested Python versions.
# Then, run setup.py with each available python, to build
- # extensions for each.
+ # extensions for each.
my $python_default = `pyversions -d`;
$python_default =~ s/^\s+//;
@@ -139,7 +139,21 @@ sub setup_py {
foreach my $python (@python_requested, @python_dbg) {
if (-x "/usr/bin/".$python) {
- $this->doit_in_sourcedir($python, "setup.py", $act, @_);
+ # To allow backports of debhelper we don't pass
+ # --install-layout=deb to 'setup.py install` for
+ # those Python versions where the option is
+ # ignored by distutils/setuptools.
+ if ( $act eq "install" and not
+ ( ($python =~ /^python(?:-dbg)?$/
+ and $python_default =~ /^python2.[2345]$/)
+ or $python =~ /^python2.[2345](?:-dbg)?$/ )) {
+ $this->doit_in_sourcedir($python, "setup.py",
+ $act, @_, "--install-layout=deb");
+ }
+ else {
+ $this->doit_in_sourcedir($python, "setup.py",
+ $act, @_);
+ }
}
}
}
@@ -156,7 +170,6 @@ sub install {
"--root=$destdir",
"--no-compile",
"-O0",
- "--install-layout=deb",
@_);
}
diff --git a/debian/changelog b/debian/changelog
index 954cfb03..0ca81c3a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+debhelper (7.3.13) unstable; urgency=low
+
+ * python_distutils.pm: Support debhelper backports.
+ To allow backports of debhelper we don't pass
+ --install-layout=deb to 'setup.py install` for those Python
+ versions where the option is ignored by distutils/setuptools.
+ Thanks to Julian Andres Klode for the bug report.
+ Closes: #539324
+
+ -- Bernd Zeimetz <bzed@debian.org> Sat, 08 Aug 2009 04:22:53 +0200
+
debhelper (7.3.12) unstable; urgency=low
* dh: Allow creation of new sequences (such as to handle a patch